summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2015-12-16 13:35:03 +0100
committerPhilipp A2015-12-16 13:35:47 +0100
commit5e2ea6e03bdbb89b760f8cd84d4f9e6d9568e0af (patch)
treedfba36723dbea2167ff26103ac9f0794c4828c4b
parent553d4b3390ad68741780af315110e2ea6a17b703 (diff)
downloadaur-5e2ea6e03bdbb89b760f8cd84d4f9e6d9568e0af.tar.gz
bumped version to 0.99.486
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--qdatastream.patch12
3 files changed, 33 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7662c424aa1f..8b2b96c3c6e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rstudio-desktop
pkgdesc = Open source and enterprise-ready professional software for the R community
- pkgver = 0.99.451
- pkgrel = 2
+ pkgver = 0.99.486
+ pkgrel = 1
url = http://www.rstudio.com/
install = rstudio-desktop.install
arch = i686
@@ -27,14 +27,16 @@ pkgbase = rstudio-desktop
conflicts = rstudio-desktop-preview-bin
noextract = core-dictionaries.zip
noextract = gin-1.5.zip
- source = rstudio-0.99.451.tar.gz::https://github.com/rstudio/rstudio/tarball/v0.99.451
+ source = rstudio-0.99.486.tar.gz::https://github.com/rstudio/rstudio/tarball/v0.99.486
source = https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip
source = https://s3.amazonaws.com/rstudio-buildtools/gwt-2.7.0.zip
source = https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
- sha256sums = f172d3017f3e5e34dda99e50eba6708bbf256f68177722b381b93b7fec375205
+ source = qdatastream.patch
+ sha256sums = e6e8dff7506f31293b319ac26ee58e4fbd8da528b8887b70e31438d8b407d3c9
sha256sums = f561f4eb5d5fe1cff95c881e6aed53a86e9f0de8a52863295a8600375f96ab94
sha256sums = aa65061b73836190410720bea422eb8e787680d7bc0c2b244ae6c9a0d24747b3
sha256sums = 4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494
+ sha256sums = 3147f02fe9fb557c7dee4d332db9626da4ac4b563ad3d00fc68c6f955afd0a41
pkgname = rstudio-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 30b021369408..8856a44d58f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Contributor: Ben Ward <benjamin.ward@bathspa.org>
# Maintainer: Alexsandr Pavlov <kidoz at mail dot ru>
pkgname=rstudio-desktop
-pkgver=0.99.451
+pkgver=0.99.486
_gwtver=2.7.0
_ginver=1.5
_clangver=3.6.1
-pkgrel=2
+pkgrel=1
pkgdesc="Open source and enterprise-ready professional software for the R community"
arch=('i686' 'x86_64')
url="http://www.rstudio.com/"
@@ -17,23 +17,31 @@ install=rstudio-desktop.install
source=("rstudio-$pkgver.tar.gz::https://github.com/rstudio/rstudio/tarball/v$pkgver"
"https://s3.amazonaws.com/rstudio-buildtools/gin-$_ginver.zip"
"https://s3.amazonaws.com/rstudio-buildtools/gwt-$_gwtver.zip"
- "https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip")
+ "https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
+ "qdatastream.patch")
noextract=('core-dictionaries.zip'
"gin-$_ginver.zip")
-sha256sums=('f172d3017f3e5e34dda99e50eba6708bbf256f68177722b381b93b7fec375205'
+sha256sums=('e6e8dff7506f31293b319ac26ee58e4fbd8da528b8887b70e31438d8b407d3c9'
'f561f4eb5d5fe1cff95c881e6aed53a86e9f0de8a52863295a8600375f96ab94'
'aa65061b73836190410720bea422eb8e787680d7bc0c2b244ae6c9a0d24747b3'
- '4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494')
+ '4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494'
+ '3147f02fe9fb557c7dee4d332db9626da4ac4b563ad3d00fc68c6f955afd0a41')
_pkgname=rstudio
+prepare() {
+ unzip -o "$srcdir/gin-$_ginver.zip" -d "gin-$_ginver"
+}
+
build() {
cd "$srcdir/$_pkgname-$_pkgname-"*
- install -d src/gwt/lib/{gin,gwt/$_gwtver}
+ patch -p 1 -i "$srcdir/qdatastream.patch"
+
+ install -d src/gwt/lib/{gin/$_ginver,gwt/$_gwtver}
+ cp -r "$srcdir/gin-$_ginver/"* "src/gwt/lib/gin/$_ginver"
cp -r "$srcdir/gwt-$_gwtver/"* "src/gwt/lib/gwt/$_gwtver"
- unzip -qfod "src/gwt/lib/gin/$_ginver" "$srcdir/gin-$_ginver.zip"
(
cd "dependencies/common"
diff --git a/qdatastream.patch b/qdatastream.patch
new file mode 100644
index 000000000000..cbaa7aea7949
--- /dev/null
+++ b/qdatastream.patch
@@ -0,0 +1,12 @@
+diff --git a/src/cpp/desktop/3rdparty/qtsingleapplication/qtlocalpeer.cpp b/src/cpp/desktop/3rdparty/qtsingleapplication/qtlocalpeer.cpp
+index 09ab680..a0e77d6 100644
+--- a/src/cpp/desktop/3rdparty/qtsingleapplication/qtlocalpeer.cpp
++++ b/src/cpp/desktop/3rdparty/qtsingleapplication/qtlocalpeer.cpp
+@@ -41,6 +41,7 @@
+
+ #include "qtlocalpeer.h"
+ #include <QCoreApplication>
++#include <QDataStream>
+ #include <QTime>
+
+ #if defined(Q_OS_WIN)