summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-01-05 12:17:52 +0100
committerPhilipp A2021-01-05 12:18:04 +0100
commit990daee2de374f96681a2743e7815bfe3dbb6561 (patch)
tree647dbc5e928ce91f7202ef03c87f7f8d18f46487
parent4a46d0687dfec0d1fc300f12e6ad38189a35e0c9 (diff)
downloadaur-990daee.tar.gz
add boost patch again …
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD7
-rwxr-xr-xbuild.sh7
4 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bb11a30fef9..970e394ea7de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rstudio-desktop
pkgdesc = Open source and enterprise-ready professional software for the R community
pkgver = 1.3.1093
- pkgrel = 1
+ pkgrel = 2
url = http://www.rstudio.com/
arch = i686
arch = x86_64
@@ -35,8 +35,10 @@ pkgbase = rstudio-desktop
noextract = gin-.zip
source = rstudio-1.3.1093.tar.gz::https://github.com/rstudio/rstudio/tarball/v1.3.1093
source = https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
+ source = https://gist.githubusercontent.com/trap000d/22b11a58c064046478967e60b3394214/raw/8bd457515431ec8c139e8f07fd86b0d2cb420d5d/rstudio-aee4453_libboost175.diff
sha256sums = 6ea169a0d59f0c3eba408d74a2590f7bf9f1e6f911b266a02f6266bf4975cec9
sha256sums = 4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494
+ sha256sums = 77e3e1cfec3c3ffebc9151f62b80db2840db022c84359c7bf17e92c288ab4973
pkgname = rstudio-desktop
diff --git a/.gitignore b/.gitignore
index 2b9090f0766c..7bd40c48c40e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,6 +6,7 @@
/gin-*.zip
/gwt-*.zip
/core-dictionaries.zip
+/*.patch
+/*.diff
-/boost-1.70.patch
-/r-nosave.patch
+/pkg-cache/
diff --git a/PKGBUILD b/PKGBUILD
index da6e91ba9d0f..ab0b3e3c1b1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rstudio-desktop
pkgver=1.3.1093
_clangver=3.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open source and enterprise-ready professional software for the R community"
arch=(i686 x86_64)
url="http://www.rstudio.com/"
@@ -26,10 +26,12 @@ conflicts=(rstudio-desktop-bin rstudio-desktop-git rstudio-desktop-preview-bin)
source=(
"rstudio-$pkgver.tar.gz::https://github.com/rstudio/rstudio/tarball/v$pkgver"
'https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip'
+ 'https://gist.githubusercontent.com/trap000d/22b11a58c064046478967e60b3394214/raw/8bd457515431ec8c139e8f07fd86b0d2cb420d5d/rstudio-aee4453_libboost175.diff'
)
noextract=('core-dictionaries.zip' "gin-$_ginver.zip")
sha256sums=('6ea169a0d59f0c3eba408d74a2590f7bf9f1e6f911b266a02f6266bf4975cec9'
- '4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494')
+ '4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494'
+ '77e3e1cfec3c3ffebc9151f62b80db2840db022c84359c7bf17e92c288ab4973')
_pkgname=rstudio
@@ -72,6 +74,7 @@ build() {
# The previous comparison doesn’t seem to work with Boost_VERSION being 1.71.0
sed -i 's/Boost_VERSION LESS 106900/Boost_VERSION VERSION_LESS 1.69.0/g' src/cpp/CMakeLists.txt
+ patch -p1 <'../rstudio-aee4453_libboost175.diff'
# Prevent java error: “Could not lock User prefs. Lock file access denied.”
# Because gwt desperately needs to add a “firstLaunch” entry there…
diff --git a/build.sh b/build.sh
index 7618300c0de5..51b749dbe1ba 100755
--- a/build.sh
+++ b/build.sh
@@ -1,12 +1,15 @@
#!/bin/bash
set -e
+# make all required packages available in pkg-cache, e.g. like this:
+
+# mkdir pkg-cache
# yay -S r-testthat
-# mv /tmp/yaytmp-1000/*/*.pkg.tar.xz .cache/yay/
+# mv /tmp/yaytmp-1000/*/*.pkg.tar.xz pkg-cache/
declare -a args
for dep in $(pactree -u r-testthat | grep '^r-'); do
- args+=('-I' "$(ls ~/.cache/yay/$dep-*)")
+ args+=('-I' "$(ls ./pkg-cache/$dep-*)")
done
extra-x86_64-build -- "${args[@]}"