summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-09-28 12:19:54 +0200
committerPhilipp A2017-09-28 12:19:54 +0200
commitffcabbefe7fe2b213c6b475fb17f6c02afca8f49 (patch)
tree1de0f33987ffdbe656d240eac8b89dc892921c65
parent312105cc0ae78ddab276b00a51b67412bf9b0630 (diff)
downloadaur-ffcabbefe7fe2b213c6b475fb17f6c02afca8f49.tar.gz
(untested) apply Trace.cpp cerr patch; update broken sha1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--trace-cerr.patch10
3 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57e5606b664c..99271507b650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rstudio-desktop
pkgdesc = Open source and enterprise-ready professional software for the R community
pkgver = 1.0.153
- pkgrel = 1
+ pkgrel = 2
url = http://www.rstudio.com/
arch = i686
arch = x86_64
@@ -37,12 +37,14 @@ pkgbase = rstudio-desktop
source = https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
source = rroutines-style.patch
source = socketproxy-openssl.patch
- sha256sums = 74438e9effff16ec6a5353476a1700c02556423eb62105d242df913888519540
+ source = trace-cerr.patch
+ sha256sums = 099ceec1480c7605285782ba5ecbf96eb6191d6f9a90e988c151578eb8bde9df
sha256sums = f561f4eb5d5fe1cff95c881e6aed53a86e9f0de8a52863295a8600375f96ab94
sha256sums = aa65061b73836190410720bea422eb8e787680d7bc0c2b244ae6c9a0d24747b3
sha256sums = 4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494
sha256sums = b953527f46320d64425f7de257f774d7f354199b7c6a71f126ed467b6e6dd52b
sha256sums = 65b9f9b1f159bbfbcb1544f444e210e58549c0d1c0c6421cf750ce3517088134
+ sha256sums = 42705a30c704d1e36ef7a9b3790e64aea868115ba102c6d1b3d87e0ba0c7f928
pkgname = rstudio-desktop
diff --git a/PKGBUILD b/PKGBUILD
index b2a5a95ae5e8..80a9e468c478 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=1.0.153
_gwtver=2.7.0
_ginver=1.5
_clangver=3.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open source and enterprise-ready professional software for the R community"
arch=(i686 x86_64)
url="http://www.rstudio.com/"
@@ -22,18 +22,20 @@ source=(
"rstudio-$pkgver.tar.gz::https://github.com/rstudio/rstudio/tarball/v$pkgver"
"https://s3.amazonaws.com/rstudio-buildtools/gin-$_ginver.zip"
"https://s3.amazonaws.com/rstudio-buildtools/gwt-$_gwtver.zip"
- "https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip"
- "rroutines-style.patch"
- "socketproxy-openssl.patch"
+ 'https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip'
+ 'rroutines-style.patch'
+ 'socketproxy-openssl.patch'
+ 'trace-cerr.patch'
)
noextract=('core-dictionaries.zip' "gin-$_ginver.zip")
sha256sums=(
- '74438e9effff16ec6a5353476a1700c02556423eb62105d242df913888519540'
+ '099ceec1480c7605285782ba5ecbf96eb6191d6f9a90e988c151578eb8bde9df'
'f561f4eb5d5fe1cff95c881e6aed53a86e9f0de8a52863295a8600375f96ab94'
'aa65061b73836190410720bea422eb8e787680d7bc0c2b244ae6c9a0d24747b3'
'4341a9630efb9dcf7f215c324136407f3b3d6003e1c96f2e5e1f9f14d5787494'
'b953527f46320d64425f7de257f774d7f354199b7c6a71f126ed467b6e6dd52b'
'65b9f9b1f159bbfbcb1544f444e210e58549c0d1c0c6421cf750ce3517088134'
+ '42705a30c704d1e36ef7a9b3790e64aea868115ba102c6d1b3d87e0ba0c7f928'
)
_pkgname=rstudio
@@ -66,6 +68,7 @@ build() {
# https://github.com/rstudio/rstudio/pull/1063/commits/e8c9a7783f3ff44dea2e2464b4bf2904325c72cd
# replicating upstream patch
patch -p 1 -i "$srcdir/socketproxy-openssl.patch"
+ patch -p 1 -i "$srcdir/trace-cerr.patch"
install -d src/gwt/lib/{gin/$_ginver,gwt/$_gwtver}
diff --git a/trace-cerr.patch b/trace-cerr.patch
new file mode 100644
index 000000000000..c0e71938f819
--- /dev/null
+++ b/trace-cerr.patch
@@ -0,0 +1,10 @@
+--- a/src/cpp/core/Trace.cpp
++++ b/src/cpp/core/Trace.cpp
+@@ -16,6 +16,7 @@
+
+ #include <core/Trace.hpp>
+
++#include <iostream>
+ #include <map>
+
+ #include <boost/utility.hpp>