summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-01-22 13:21:10 +0100
committerbartus2021-01-23 10:56:49 +0100
commit3d80bdea3612f33b5672e213d40d494f76358622 (patch)
tree33b71a749ee0830988f32b94c699818d04f4cdfc
parent7bd2045d2b751cf3c37779d53fb06f47d76bf649 (diff)
downloadaur-3d80bdea3612f33b5672e213d40d494f76358622.tar.gz
Fix missing yaml-cpp
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 204b82e011a3..3748914f5271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,6 +32,7 @@ pkgbase = rstudio-desktop-git
depends = hunspell-en_US
depends = mathjax2
depends = pandoc
+ depends = yaml-cpp
optdepends = git: for git support
optdepends = subversion: for subversion support
optdepends = openssh-askpass: for a git ssh access
diff --git a/PKGBUILD b/PKGBUILD
index 56454fadd6f3..4c28121f6379 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgdesc="A powerful and productive integrated development environment (IDE) for
arch=('i686' 'x86_64')
url="https://www.rstudio.com/products/rstudio/"
license=('AGPL3')
-depends=('r>=3.0.1' boost-libs qt5-sensors qt5-svg qt5-webengine qt5-xmlpatterns postgresql-libs sqlite3 soci clang hunspell-en_US mathjax2 pandoc)
+depends=('r>=3.0.1' boost-libs qt5-sensors qt5-svg qt5-webengine qt5-xmlpatterns postgresql-libs sqlite3 soci clang hunspell-en_US mathjax2 pandoc yaml-cpp)
makedepends=(git 'cmake>=3.1.0' boost desktop-file-utils jdk8-openjdk apache-ant unzip openssl libcups pam patchelf wget yarn)
optdepends=('git: for git support'
'subversion: for subversion support'
@@ -75,6 +75,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr/lib/rstudio \
-DRSTUDIO_USE_SYSTEM_BOOST=yes \
+ -DRSTUDIO_USE_SYSTEM_YAML_CPP=yes \
-DQT_QMAKE_EXECUTABLE=/usr/bin/qmake \
-DBoost_NO_BOOST_CMAKE=ON \
-DRSTUDIO_USE_SYSTEM_SOCI=yes \