summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2022-06-28 15:18:54 +0200
committerYann Büchau2022-06-28 15:18:54 +0200
commitf36a13935263bb199fadcb577ec38c1b99bd537e (patch)
tree11eff6bc454354dac4a9e52328f74f6de4d301fe
parent98bec26328f74a6f45584e9dd1b19046bb22e521 (diff)
downloadaur-f36a13935263bb199fadcb577ec38c1b99bd537e.tar.gz
[prepare] Warn about non-matching node version
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16b27098cb4d..4f87cfd57fb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,6 +52,23 @@ EOT
exit 1
fi
+ _rstudio_node_version=$(perl -ne 'print "$1" if(m/RSTUDIO_NODE_VERSION\s*"([^"]+)/)' "$srcdir"/rstudio/src/node/CMakeNodeTools.txt)
+ if test "$_nodever" != "$_rstudio_node_version";then
+ cat<<EOT
+ node version in PKGBUILD ($_nodever) does not match what RStudio server expects ($_rstudio_node_version).
+
+ Fix it by updating the \$_nodever variable in the PKGBUILD:
+
+ ...
+ \$_nodever="$_rstudio_node_version"
+ ...
+
+ Then clean the PKGBUILD repo (git clean -ffdx), update the pkgsums (updpkgsums) and rebuild (makepkg -sf)
+
+EOT
+ exit 1
+ fi
+
cd ${srcdir}/$_gitname
# Patching SOCI
# patch -p1 < ${srcdir}/soci.patch