summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoreymwamba2015-09-18 12:25:01 +0100
committercoreymwamba2015-09-18 12:25:01 +0100
commit2b5d95f54d12bd04f35f5defaaf2ff3b12c6abaa (patch)
tree54b854355bb04f750dfd1caf71e4d524933de288
downloadaur-2b5d95f54d12bd04f35f5defaaf2ff3b12c6abaa.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--RtAudio.patch11
-rw-r--r--alsa.patch11
-rw-r--r--pvc.patch12
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af2e068a9057
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = rt_pvc
+ pkgdesc = real-time phase vocoder
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://soundlab.cs.princeton.edu/software/rt_pvc/
+ arch = i686
+ arch = x86_64
+ groups = multimedia
+ license = GPL
+ depends = alsa-lib
+ depends = glu
+ depends = freeglut
+ depends = libxmu
+ provides = rt_pvc
+ source = http://soundlab.cs.princeton.edu/software/rt_pvc/files/rt_pvc-1.0.0.tgz
+ source = RtAudio.patch
+ source = alsa.patch
+ source = pvc.patch
+ md5sums = 0a99b4f17038dd76c172735dbf7f2d15
+ md5sums = 8cdab915ec05f8fe8b256305f8803b78
+ md5sums = 1880c9f919b92ee95d7a8ea3e2e2b905
+ md5sums = 6340e9c2a16ba0ff311457e5c0eb81f3
+
+pkgname = rt_pvc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d968d6d8132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Corey Mwamba <contact.me@coreymwamba.co.uk>
+pkgname=rt_pvc
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="real-time phase vocoder"
+arch=('i686' 'x86_64')
+url="http://soundlab.cs.princeton.edu/software/rt_pvc/"
+license=('GPL')
+groups=('multimedia')
+depends=('alsa-lib' 'glu' 'freeglut' 'libxmu')
+provides=('rt_pvc')
+source=("http://soundlab.cs.princeton.edu/software/$pkgname/files/$pkgname-$pkgver.tgz" "RtAudio.patch" "alsa.patch" "pvc.patch")
+md5sums=('0a99b4f17038dd76c172735dbf7f2d15'
+ '8cdab915ec05f8fe8b256305f8803b78'
+ '1880c9f919b92ee95d7a8ea3e2e2b905'
+ '6340e9c2a16ba0ff311457e5c0eb81f3')
+
+prepare() {
+ cd "$srcdir"
+ patch -i "RtAudio.patch"
+ patch -i "alsa.patch"
+ patch -i "pvc.patch"
+}
+
+build() {
+ cd "$srcdir"
+ make -f makefile.alsa
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p /usr/bin
+ cd "$srcdir"
+ install -p -D $pkgname -m 0755 $pkgdir/usr/bin/$pkgname
+}
diff --git a/RtAudio.patch b/RtAudio.patch
new file mode 100644
index 000000000000..0068e9ea6ac8
--- /dev/null
+++ b/RtAudio.patch
@@ -0,0 +1,11 @@
+--- RtAudio.cpp 2004-10-25 09:17:30.000000000 +0100
++++ RtAudio.new.cpp 2015-09-18 10:22:47.281883179 +0100
+@@ -38,7 +38,7 @@
+ /************************************************************************/
+
+ // RtAudio: Version 3.0.1, 22 March 2004
+-
++#include <cstdio>
+ #include "RtAudio.h"
+ #include <iostream>
+
diff --git a/alsa.patch b/alsa.patch
new file mode 100644
index 000000000000..96154b15024e
--- /dev/null
+++ b/alsa.patch
@@ -0,0 +1,11 @@
+--- makefile.alsa 2004-05-12 03:46:46.000000000 +0100
++++ makefile.alsa.dif 2015-09-18 12:13:40.762703223 +0100
+@@ -5,7 +5,7 @@
+ CPP=g++
+ INCLUDES=
+ CFLAGS=-D__LINUX_ALSA__ $(INCLUDES) -O3 -g -c
+-LIBS=-lasound -L/usr/X11R6/lib -lGL -lGLU -lglut -lX11 -lXi -lXext -lXmu -lm
++LIBS=-lasound -L/usr/X11R6/lib -lGL -lGLU -lglut -lX11 -lXi -lXext -lXmu -lm -lpthread
+
+ rt_pvc: $(OBJS)
+ $(CPP) -o $@ $(OBJS) $(LIBS)
diff --git a/pvc.patch b/pvc.patch
new file mode 100644
index 000000000000..3558f67e8a7c
--- /dev/null
+++ b/pvc.patch
@@ -0,0 +1,12 @@
+--- pvc.cpp 2004-05-11 23:46:51.000000000 +0100
++++ pvc.cpp.dif 2015-09-18 12:19:53.652041464 +0100
+@@ -11,6 +11,9 @@
+ #include <assert.h>
+ #include <memory.h>
+ #include <queue>
++#include <cstring>
++#include <cstdio>
++#include <cstdlib>
+ using namespace std;
+
+