summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-27 12:30:56 +0800
committermaz-12015-10-27 12:30:56 +0800
commit3c5dd2a845123eac1f8115d7d0bf7c1f3664a60f (patch)
treecc0ddd023f116fa8c050401a4b5b0cce9cc9c15c
downloadaur-3c5dd2a845123eac1f8115d7d0bf7c1f3664a60f.tar.gz
init
-rw-r--r--.SRCINFO34
-rw-r--r--Makefile.local40
-rw-r--r--PKGBUILD108
-rw-r--r--create_pk3.sh18
-rw-r--r--rtcwcoop-git.install14
-rw-r--r--rtcwcoop.desktop11
-rw-r--r--rtcwcoop.launcher4
-rw-r--r--rtcwcoop.pngbin0 -> 119809 bytes
-rw-r--r--rtcwcoopded.launcher4
9 files changed, 233 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdefac57beb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = rtcwcoop-git
+ pkgdesc = A Return to Castle Wolfenstein modification which enables cooperative gameplay, based on iortcw
+ pkgver = 1634
+ pkgrel = 1
+ url = http://www.rtcwcoop.com
+ install = rtcwcoop-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = wolf-data
+ depends = sdl2
+ depends = opus
+ depends = opusfile
+ depends = libogg
+ depends = zlib
+ source = rtcwcoop::git+https://github.com/rtcwcoop/rtcwcoop.git
+ source = rtcwcoop.launcher
+ source = rtcwcoopded.launcher
+ source = Makefile.local
+ source = create_pk3.sh
+ source = rtcwcoop.png
+ source = rtcwcoop.desktop
+ md5sums = SKIP
+ md5sums = e08aab38a8574877258986038f043f89
+ md5sums = 6630b979c5f9b4ea6e7ff0e2927fa1e1
+ md5sums = 53a8ec6a5b3a67f73fe876dbe2384b95
+ md5sums = cbdfd0fcc3b6ca0bec6cc28c0ec66aa8
+ md5sums = bf26dc4c10d4bbfbd0c7a052a00c3cdf
+ md5sums = 14c6aa8ae50bb3b1d926b9cb5cd97e3b
+
+pkgname = rtcwcoop-git
+
diff --git a/Makefile.local b/Makefile.local
new file mode 100644
index 000000000000..e75aafba9bac
--- /dev/null
+++ b/Makefile.local
@@ -0,0 +1,40 @@
+#CFLAGS # use this for custom CFLAGS
+#V # set to show cc command line when building
+#DEFAULT_BASEDIR # extra path to search for main and such
+#BUILD_SERVER # build the 'iowolfmpded' server binary
+#BUILD_CLIENT # build the 'iowolfmp' or 'iowolfsp' client binary
+#BUILD_BASEGAME # build the 'main' binaries
+#BUILD_GAME_SO # build the game shared libraries
+#BUILD_GAME_QVM # build the game qvms
+#BUILD_STANDALONE # build binaries suited for stand-alone games
+#SERVERBIN # rename 'iowolfmpded' server binary
+#CLIENTBIN # rename 'iowolfmp' or 'iowolfsp' client binary
+#BASEGAME # rename 'main'
+#BASEGAME_CFLAGS # custom CFLAGS for basegame
+#USE_OPENAL # use OpenAL where available
+#USE_OPENAL_DLOPEN # link with OpenAL at runtime
+#USE_CURL # use libcurl for http/ftp download support
+#USE_CURL_DLOPEN # link with libcurl at runtime
+#USE_CODEC_VORBIS # enable Ogg Vorbis support
+#USE_CODEC_OPUS # enable Ogg Opus support
+#USE_MUMBLE # enable Mumble support
+#USE_VOIP # # enable built-in VoIP support
+#USE_INTERNAL_SPEEX # build internal speex library instead of dynamically linking against system libspeex
+#USE_FREETYPE # enable FreeType support for rendering fonts
+#USE_INTERNAL_ZLIB # build and link against internal zlib
+#USE_INTERNAL_JPEG # build and link against internal JPEG library
+#USE_INTERNAL_OGG # build and link against internal ogg library
+#USE_INTERNAL_OPUS # build and link against internal opus/opusfile libraries
+#USE_LOCAL_HEADERS # use headers local to ioq3 instead of system ones
+#DEBUG_CFLAGS # C compiler flags to use for building debug version
+#COPYDIR # the target installation directory
+#TEMPDIR # specify userdefined directory for temp files
+CFLAGS=-march=native -mtune=native -O3 -pipe
+USE_INTERNAL_SPEEX=0
+USE_INTERNAL_ZLIB=0
+USE_INTERNAL_JPEG=0
+USE_INTERNAL_OGG=0
+USE_INTERNAL_OPUS=0
+USE_LOCAL_HEADERS=0
+CLIENT_CFLAGS+=-I/usr/include/opus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c974f5e072a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,108 @@
+# Maintainer: M0Rf30
+pkgname=rtcwcoop-git
+pkgver=1634
+pkgrel=1
+pkgdesc="A Return to Castle Wolfenstein modification which enables cooperative gameplay, based on iortcw"
+arch=('i686' 'x86_64')
+url="http://www.rtcwcoop.com"
+license=('GPL')
+depends=('wolf-data' 'sdl2' 'opus' 'opusfile' 'libogg' 'zlib')
+makedepends=('cmake' 'git')
+install='rtcwcoop-git.install'
+source=("rtcwcoop::git+https://github.com/rtcwcoop/rtcwcoop.git"
+ 'rtcwcoop.launcher'
+ 'rtcwcoopded.launcher'
+ 'Makefile.local'
+ 'create_pk3.sh'
+ 'rtcwcoop.png'
+ 'rtcwcoop.desktop')
+md5sums=('SKIP'
+ 'e08aab38a8574877258986038f043f89'
+ '6630b979c5f9b4ea6e7ff0e2927fa1e1'
+ '53a8ec6a5b3a67f73fe876dbe2384b95'
+ 'cbdfd0fcc3b6ca0bec6cc28c0ec66aa8'
+ 'bf26dc4c10d4bbfbd0c7a052a00c3cdf'
+ '14c6aa8ae50bb3b1d926b9cb5cd97e3b')
+pkgver() {
+ cd "$srcdir/$pkgname/"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+
+build() {
+ cd rtcwcoop
+ if [ ! -f /opt/wolf-data/pak0.pk3 ]; then
+ echo "pak0.pk3 doesn't exist. This process will be terminated"
+ echo "Follow the wolf-data package instructions!"
+ exit 1
+ fi
+
+ cp $srcdir/Makefile.local .
+ make release -j4
+}
+
+package() {
+ cd rtcwcoop
+
+ mkdir -p $pkgdir/opt/rtcwcoop/{coopmain,main}
+
+ make COPYDIR=$pkgdir/opt/rtcwcoop/ copyfiles
+
+ ln -s -r /opt/wolf-data/mp_bin.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak0.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak1.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak2.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak3.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak4.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pak5.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps0.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps1.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps2.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps3.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps4.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps5.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/mp_pakmaps6.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/scripts $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/pak0.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/sp_pak1.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/sp_pak2.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/sp_pak3.pk3 $pkgdir/opt/rtcwcoop/main
+ ln -s -r /opt/wolf-data/rotate.cfg $pkgdir/opt/rtcwcoop/main
+
+ # Create Coop PK3
+ cp $srcdir/create_pk3.sh .
+ ./create_pk3.sh
+ cp media/*.pk3 $pkgdir/opt/rtcwcoop/coopmain
+
+ # Modify Launcher Scripts
+ if [ "$CARCH" = "x86_64" ]; then
+ #
+ # x86_64 Systems
+ #
+ sed -i "s:ARCH:x86_64:" \
+ $srcdir/rtcwcoop.launcher
+ sed -i "s:ARCH:x86_64:" \
+ $srcdir/rtcwcoopded.launcher
+ else
+ #
+ # i686 Systems
+ #
+ sed -i "s:ARCH:i386:" \
+ $srcdir/rtcwcoop.launcher
+ sed -i "s:ARCH:i386:" \
+ $srcdir/rtcwcoopded.launcher
+ fi
+
+
+ # Install Launcher Script (Single Player Client)
+ install -D -m 755 $srcdir/rtcwcoop.launcher \
+ $pkgdir/usr/bin/rtcwcoop
+ # Install Launcher Script (Multi Player Client)
+ install -D -m 755 $srcdir/rtcwcoopded.launcher \
+ $pkgdir/usr/bin/rtcwcoopded
+
+ install -Dm644 $srcdir/rtcwcoop.png $pkgdir/usr/share/pixmaps/rtcwcoop.png
+ install -Dm755 $srcdir/rtcwcoop.desktop $pkgdir/usr/share/applications/rtcwcoop.desktop
+}
+
+
diff --git a/create_pk3.sh b/create_pk3.sh
new file mode 100644
index 000000000000..c83974709395
--- /dev/null
+++ b/create_pk3.sh
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+PAKFILE=sp_pak_coop1.pk3
+ORIGINALFOLDER=$(pwd)
+
+cd media/sp_pak_coop1
+
+zip -r $PAKFILE ./ -x "*.svn*"
+
+mv $PAKFILE ../
+
+echo "Creating bin.pk3"
+ cd ../../build/release-linux*
+ cd coopmain/
+ zip -r bin.pk3 *.so
+ cp bin.pk3 ~/.wolf/coopmain/
+ mv bin.pk3 ../../../media/
+
diff --git a/rtcwcoop-git.install b/rtcwcoop-git.install
new file mode 100644
index 000000000000..a30fc11073ab
--- /dev/null
+++ b/rtcwcoop-git.install
@@ -0,0 +1,14 @@
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ echo ">>> To complete the uninstallation remove the RtCW data directory:"
+ echo ">>> rm -r /opt/rtcwcoop/"
+ echo ">>>"
+}
+op=$1
+shift
+
+$op $*
+
diff --git a/rtcwcoop.desktop b/rtcwcoop.desktop
new file mode 100644
index 000000000000..4091b68583a5
--- /dev/null
+++ b/rtcwcoop.desktop
@@ -0,0 +1,11 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Return To Castle Wolfenstein
+Comment=Return To Castle Wolfenstein
+Exec=/usr/bin/rtcwcoop
+Icon=rtcwcoop
+Terminal=false
+Categories=Game
+
diff --git a/rtcwcoop.launcher b/rtcwcoop.launcher
new file mode 100644
index 000000000000..334c619521d0
--- /dev/null
+++ b/rtcwcoop.launcher
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd "/opt/rtcwcoop"
+exec ./rtcwcoop.ARCH +set cl_renderer rend2 "$@"
+
diff --git a/rtcwcoop.png b/rtcwcoop.png
new file mode 100644
index 000000000000..1a22369b23c6
--- /dev/null
+++ b/rtcwcoop.png
Binary files differ
diff --git a/rtcwcoopded.launcher b/rtcwcoopded.launcher
new file mode 100644
index 000000000000..4c2fa168ec5b
--- /dev/null
+++ b/rtcwcoopded.launcher
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd "/opt/rtcwcoop"
+exec ./rtcwcoopded.ARCH "$@"
+