summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302017-09-10 17:59:06 +0200
committerM0Rf302017-09-10 17:59:06 +0200
commitcdee13418e20993b9e983b49fc644a88dc27bc6c (patch)
tree4809320cba0122b4d113fbec99e8702bdc5d9afd
parent7374def840a0dcc698ba519197d0d1054856f62b (diff)
downloadaur-cdee13418e20993b9e983b49fc644a88dc27bc6c.tar.gz
rtcwcoop-git: updated and some cleanups
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.local40
-rw-r--r--PKGBUILD35
3 files changed, 19 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdefac57beb9..4a4a4dcc6729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Sun Sep 10 15:58:48 UTC 2017
pkgbase = rtcwcoop-git
pkgdesc = A Return to Castle Wolfenstein modification which enables cooperative gameplay, based on iortcw
pkgver = 1634
@@ -18,17 +20,15 @@ pkgbase = rtcwcoop-git
source = rtcwcoop::git+https://github.com/rtcwcoop/rtcwcoop.git
source = rtcwcoop.launcher
source = rtcwcoopded.launcher
- source = Makefile.local
source = create_pk3.sh
source = rtcwcoop.png
source = rtcwcoop.desktop
md5sums = SKIP
md5sums = e08aab38a8574877258986038f043f89
md5sums = 6630b979c5f9b4ea6e7ff0e2927fa1e1
- md5sums = 53a8ec6a5b3a67f73fe876dbe2384b95
md5sums = cbdfd0fcc3b6ca0bec6cc28c0ec66aa8
md5sums = bf26dc4c10d4bbfbd0c7a052a00c3cdf
- md5sums = 14c6aa8ae50bb3b1d926b9cb5cd97e3b
+ md5sums = f24dc703585569ba11ba0b94625ee8e0
pkgname = rtcwcoop-git
diff --git a/Makefile.local b/Makefile.local
deleted file mode 100644
index e75aafba9bac..000000000000
--- a/Makefile.local
+++ /dev/null
@@ -1,40 +0,0 @@
-#CFLAGS # use this for custom CFLAGS
-#V # set to show cc command line when building
-#DEFAULT_BASEDIR # extra path to search for main and such
-#BUILD_SERVER # build the 'iowolfmpded' server binary
-#BUILD_CLIENT # build the 'iowolfmp' or 'iowolfsp' client binary
-#BUILD_BASEGAME # build the 'main' binaries
-#BUILD_GAME_SO # build the game shared libraries
-#BUILD_GAME_QVM # build the game qvms
-#BUILD_STANDALONE # build binaries suited for stand-alone games
-#SERVERBIN # rename 'iowolfmpded' server binary
-#CLIENTBIN # rename 'iowolfmp' or 'iowolfsp' client binary
-#BASEGAME # rename 'main'
-#BASEGAME_CFLAGS # custom CFLAGS for basegame
-#USE_OPENAL # use OpenAL where available
-#USE_OPENAL_DLOPEN # link with OpenAL at runtime
-#USE_CURL # use libcurl for http/ftp download support
-#USE_CURL_DLOPEN # link with libcurl at runtime
-#USE_CODEC_VORBIS # enable Ogg Vorbis support
-#USE_CODEC_OPUS # enable Ogg Opus support
-#USE_MUMBLE # enable Mumble support
-#USE_VOIP # # enable built-in VoIP support
-#USE_INTERNAL_SPEEX # build internal speex library instead of dynamically linking against system libspeex
-#USE_FREETYPE # enable FreeType support for rendering fonts
-#USE_INTERNAL_ZLIB # build and link against internal zlib
-#USE_INTERNAL_JPEG # build and link against internal JPEG library
-#USE_INTERNAL_OGG # build and link against internal ogg library
-#USE_INTERNAL_OPUS # build and link against internal opus/opusfile libraries
-#USE_LOCAL_HEADERS # use headers local to ioq3 instead of system ones
-#DEBUG_CFLAGS # C compiler flags to use for building debug version
-#COPYDIR # the target installation directory
-#TEMPDIR # specify userdefined directory for temp files
-CFLAGS=-march=native -mtune=native -O3 -pipe
-USE_INTERNAL_SPEEX=0
-USE_INTERNAL_ZLIB=0
-USE_INTERNAL_JPEG=0
-USE_INTERNAL_OGG=0
-USE_INTERNAL_OPUS=0
-USE_LOCAL_HEADERS=0
-CLIENT_CFLAGS+=-I/usr/include/opus
-
diff --git a/PKGBUILD b/PKGBUILD
index 32d33015ff1e..7ec51221ce23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,41 +12,33 @@ install='rtcwcoop-git.install'
source=("rtcwcoop::git+https://github.com/rtcwcoop/rtcwcoop.git"
'rtcwcoop.launcher'
'rtcwcoopded.launcher'
- 'Makefile.local'
'create_pk3.sh'
'rtcwcoop.png'
'rtcwcoop.desktop')
-md5sums=('SKIP'
- 'e08aab38a8574877258986038f043f89'
- '6630b979c5f9b4ea6e7ff0e2927fa1e1'
- '53a8ec6a5b3a67f73fe876dbe2384b95'
- 'cbdfd0fcc3b6ca0bec6cc28c0ec66aa8'
- 'bf26dc4c10d4bbfbd0c7a052a00c3cdf'
- 'f24dc703585569ba11ba0b94625ee8e0')
+
pkgver() {
- cd "$srcdir/$pkgname/"
+ cd "$srcdir/$pkgname"
git log -1 --format="%cd" --date=short | sed 's|-||g'
}
build() {
- cd rtcwcoop
if [ ! -f /opt/wolf-data/pak0.pk3 ]; then
- echo "pak0.pk3 doesn't exist. This process will be terminated"
- echo "Follow the wolf-data package instructions!"
- exit 1
+ echo "pak0.pk3 doesn't exist. The game will not start"
+ echo "Follow the iortcw-data package instructions!"
+ sleep 5
fi
-
- cp $srcdir/Makefile.local .
- make release
}
package() {
- cd rtcwcoop
mkdir -p $pkgdir/opt/rtcwcoop/{coopmain,main}
+ cd rtcwcoop
- make COPYDIR=$pkgdir/opt/rtcwcoop/ copyfiles
+ cd SP
+ make USE_INTERNAL_LIBS=0 COPYDIR=$pkgdir/opt/rtcwcoop/ copyfiles
+ cd ../MP
+ make USE_INTERNAL_LIBS=0 COPYDIR=$pkgdir/opt/rtcwcoop/ copyfiles
ln -s -r /opt/wolf-data/mp_bin.pk3 $pkgdir/opt/rtcwcoop/main
ln -s -r /opt/wolf-data/mp_pak0.pk3 $pkgdir/opt/rtcwcoop/main
@@ -105,4 +97,9 @@ package() {
install -Dm755 $srcdir/rtcwcoop.desktop $pkgdir/usr/share/applications/rtcwcoop.desktop
}
-
+md5sums=('SKIP'
+ 'e08aab38a8574877258986038f043f89'
+ '6630b979c5f9b4ea6e7ff0e2927fa1e1'
+ 'cbdfd0fcc3b6ca0bec6cc28c0ec66aa8'
+ 'bf26dc4c10d4bbfbd0c7a052a00c3cdf'
+ 'f24dc703585569ba11ba0b94625ee8e0')