summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-21 01:27:39 -0500
committerclintval2017-12-21 01:27:39 -0500
commit706a78dc6dc2d787482457a76ec1f158295a8b8e (patch)
treec4bb49cc5c0b935ae9264e5919536771e81bacc2
downloadaur-706a78dc6dc2d787482457a76ec1f158295a8b8e.tar.gz
First commit with PKGBUILD, .SRCINFO, rtg.cfg, and rtg.sh for bash completions
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD58
-rw-r--r--rtg.cfg68
-rwxr-xr-xrtg.sh1
4 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2364c22ee2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rtg-tools
+ pkgdesc = Utilities for accurate VCF comparison and manipulation
+ pkgver = 3.8.4
+ pkgrel = 1
+ url = https://github.com/RealTimeGenomics/rtg-tools
+ arch = i686
+ arch = x86_64
+ license = Simplified BSD
+ makedepends = apache-ant>1.9
+ depends = java-runtime>=1.8
+ source = https://github.com/RealTimeGenomics/rtg-tools/archive/3.8.4.tar.gz
+ source = rtg.cfg
+ source = rtg.sh
+ md5sums = c5b558cbe845fcb315e943162b7da38e
+ md5sums = 1e5e1f5df474ab87b5a28a9d694e4e17
+ md5sums = 64a6dc8d7c7ed9c3e0ba3d8c42f8194d
+
+pkgname = rtg-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b21c6ee407a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=rtg-tools
+pkgver=3.8.4
+pkgrel=1
+pkgdesc="Utilities for accurate VCF comparison and manipulation"
+arch=('i686' 'x86_64')
+url="https://github.com/RealTimeGenomics/rtg-tools"
+license=('Simplified BSD')
+depends=('java-runtime>=1.8')
+makedepends=('apache-ant>1.9')
+source=(
+ "https://github.com/RealTimeGenomics/${pkgname}/archive/${pkgver}.tar.gz"
+ "rtg.cfg"
+ "rtg.sh")
+md5sums=(
+ 'c5b558cbe845fcb315e943162b7da38e'
+ '1e5e1f5df474ab87b5a28a9d694e4e17'
+ '64a6dc8d7c7ed9c3e0ba3d8c42f8194d')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ant zip-nojre
+ unzip -qn dist/rtg-tools-3.8.4-*-nojre.zip
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ant runalltests
+}
+
+package() {
+ cd "${srcdir}"
+ # Add environment variable to specify custom location of RTG.jar
+ install -Dm655 rtg.cfg "${pkgdir}/etc/rtg.cfg"
+ echo "RTG_JAR=/usr/share/java/${pkgname}/RTG.jar" >> "${pkgdir}/etc/rtg.cfg"
+
+ # Install primary JAR file
+ cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}-${pkgver}-"*
+ install -Dm655 RTG.jar "${pkgdir}/usr/share/java/${pkgname}/RTG.jar"
+
+ # Remove the need for a local configuration file, respect only system config
+ install -Dm755 rtg "${pkgdir}/usr/bin/rtg"
+ sed -i "s#\$THIS_DIR/rtg.cfg#${pkgdir}/etc/rtg.cfg#g" "${pkgdir}/usr/bin/rtg"
+
+ # Install demo script, data, and bash completions scrips
+ cp -r scripts "${pkgdir}/usr/share/${pkgname}"
+
+ # Install completion hook in profile.d to be sourced with each shell
+ install -Dm755 "scripts/rtg-bash-completion" "${pkgdir}/etc/profile.d/rtg-bash-completer.sh"
+
+ # Licenses and documentation
+ install -Dm655 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -Dm655 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README.txt"
+ install -Dm655 ReleaseNotes.txt "${pkgdir}/usr/share/doc/${pkgname}/ReleaseNotes.txt"
+ install -Dm655 RTGOperationsManual.pdf "${pkgdir}/usr/share/doc/${pkgname}/RTGOperationsManual.pdf"
+ cp -r RTGOperationsManual "${pkgdir}/usr/share/doc/${pkgname}/RTGOperationsManual"
+}
diff --git a/rtg.cfg b/rtg.cfg
new file mode 100644
index 000000000000..ffc448b78fe0
--- /dev/null
+++ b/rtg.cfg
@@ -0,0 +1,68 @@
+# Configuration file for RTG.
+
+# This file is automatically created upon first run, and may be edited
+# to allow some customization of default behaviour. In a
+# multi-machine environment, this file can be used to achieve
+# machine-specific configuration either by placing in /etc/rtg.cfg on
+# each machine or in the rtg installation directory values with the
+# name rtg.$(hostname -s).cfg, e.g. rtg.bioinformatics.cfg
+
+
+# The path to the java executable (need not be full path if in $PATH).
+# If unset, RTG will use the bundled JRE if present, otherwise
+# will expect java to be on $PATH
+# RTG_JAVA="java"
+
+# Amount of memory to allocate to RTG. Use G suffix for gigabytes.
+# If unset, allow RTG to use up to 90% of available RAM (see RTG_MEM_PCT)
+# RTG_MEM="4G"
+# Note that memory allocation can also be overridden on a per-command basis, e.g:
+# $ rtg RTG_MEM=24G population ...
+
+# If RTG_MEM is unset, use this percentage of total RAM.
+# The default is 90 percent.
+# RTG_MEM_PCT=90
+
+
+# Attempt to send crash logs to Real Time Genomics, true to enable, false to disable
+RTG_TALKBACK=false
+
+# Enable simple usage logging, true to enable. Default is no logging.
+RTG_USAGE=
+
+# Server URL when usage logging to a server. Default is to use RTG hosted server.
+# RTG_USAGE_HOST=
+
+# If performing single-user file-based usage logging, this specifies the directory to log to.
+# RTG_USAGE_DIR=
+
+# List of optional fields to add to usage logging (when enabled).
+# If unset do not add any of these fields. (commandline may contain information
+# considered sensitive)
+# RTG_USAGE_OPTIONAL=username,hostname,commandline
+RTG_USAGE_OPTIONAL=username,hostname
+
+
+# Allows specification of the HTTP proxy to use for
+# talkback/usage, specified in host:port form.
+# If unset, assume no http proxy is required.
+# RTG_PROXY=my.proxy.host:3128
+
+
+# Directory in which to look for pipeline reference datasets.
+# If unset, uses the references subdirectory of this installation.
+# RTG_REFERENCES_DIR=
+
+# Directory in which to look for AVR models.
+# If unset, uses the models subdirectory of this installation.
+# RTG_MODELS_DIR=
+
+# Allows passing additional arguments passed to the JVM. e.g:
+# RTG_JAVA_OPTS="-Djava.io.tmpdir=XXYY -XX:+UseLargePages"
+
+
+# Set the number of threads to use when not otherwise specified via command line flags.
+# The default behavior is to allocate one thread per machine core.
+# RTG_DEFAULT_THREADS=1
+
+
diff --git a/rtg.sh b/rtg.sh
new file mode 100755
index 000000000000..8ce677e7891f
--- /dev/null
+++ b/rtg.sh
@@ -0,0 +1 @@
+source /etc/share/rtg-tools/rtg-bash-completion