summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2016-01-13 12:17:09 +0100
committerNeoTheFox2016-01-13 12:17:09 +0100
commitdb12f50809cfae379fe4a848a5e4bc63145ee59f (patch)
tree0870e86f70b0eaa7d8d761a1dbaf392b6cadc682
downloadaur-db12f50809cfae379fe4a848a5e4bc63145ee59f.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..503d0cba2bfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 11:16:49 UTC 2016
+pkgbase = rtile-git
+ pkgdesc = Ruby script for manual tiling and window placement.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/xhsdf/rtile
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ depends = ruby
+ depends = xorg-xprop
+ depends = wmctrl
+ depends = xorg-xrandr
+ provides = rtile
+ conflicts = rtile
+ source = rtile-git::git://github.com/xhsdf/rtile.git
+ md5sums = SKIP
+
+pkgname = rtile-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af46db1ebde8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=rtile-git
+pkgver=1
+pkgrel=1
+pkgdesc="Ruby script for manual tiling and window placement."
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/xhsdf/rtile"
+license=('GPL')
+depends=('ruby' 'xorg-xprop' 'wmctrl' 'xorg-xrandr')
+makedepends=('git')
+conflicts=('rtile')
+provides=('rtile')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/xhsdf/rtile.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "rtile.rb" "$pkgdir/usr/bin/rtile"
+}