summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedlyk2021-02-05 17:32:50 +0100
committerknedlyk2021-02-05 17:32:50 +0100
commitd862af07753b3094052d78e37a39d75a81a8d4ff (patch)
treee0e339e21424f3cbf01e1bcce16a6c0e8e62f5be
downloadaur-d862af07753b3094052d78e37a39d75a81a8d4ff.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--depmod.install14
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4475f06a417
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rtl8761usb
+ pkgdesc = Realtek bluetooth modules for RTL8761 usb based devices
+ pkgver = 20201202
+ pkgrel = 1
+ url = https://www.xmpow.com/pages/download
+ install = depmod.install
+ arch = any
+ license = unknown
+ makedepends = linux-headers
+ depends = linux
+ conflicts = rtl8761b-fw
+ source = https://mpow.s3-us-west-1.amazonaws.com/20201202_mpow_BH456A_driver+for+Linux.7z
+ md5sums = 994ad1d6f6bd1e63190dfef7f64bbb34
+
+pkgname = rtl8761usb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2bf22d3d1e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Yarema aka Knedlyk <yupadmin@gmail.com>
+
+pkgname=rtl8761usb
+pkgver=20201202
+pkgrel=1
+pkgdesc="Realtek bluetooth modules for RTL8761 usb based devices"
+arch=('any')
+url="https://www.xmpow.com/pages/download"
+license=('unknown')
+source=("https://mpow.s3-us-west-1.amazonaws.com/${pkgver}_mpow_BH456A_driver+for+Linux.7z")
+conflicts=('rtl8761b-fw')
+depends=('linux')
+makedepends=('linux-headers')
+install=depmod.install
+
+prepare() {
+ cd ${pkgver}_LINUX_BT_DRIVER
+ sed -i 's/=\ \/lib/=\ \.\/lib/g' Makefile
+ sed -i 's/=\ \/lib/=\ \.\.\/lib/g' */Makefile
+ sed -i 's/depmod/\# depmod/g' */Makefile
+}
+package() {
+ cd ${pkgver}_LINUX_BT_DRIVER
+ make install INTERFACE=usb
+ install -d "$pkgdir/usr/lib/"
+ cp -r lib/* "$pkgdir/usr/lib/"
+}
+md5sums=('994ad1d6f6bd1e63190dfef7f64bbb34')
diff --git a/depmod.install b/depmod.install
new file mode 100644
index 000000000000..a18ed546237d
--- /dev/null
+++ b/depmod.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ EXTRAMODULES="$(basename $(readlink -f /lib/modules/$(uname -r)/extramodules/))"
+ depmod "$(uname -r)"
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}
+
+# vim:set ts=2 sw=2 et: