summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Conzelmann2019-07-10 23:04:08 +0200
committerManuel Conzelmann2019-07-10 23:23:11 +0200
commitbd87ec98d6cda7ae61498c39fd763f9198698858 (patch)
tree148a3d3a552ce333ba3ddbab5d364facc7d3ff1c
downloadaur-bd87ec98d6cda7ae61498c39fd763f9198698858.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02a0c481a14c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = rtl8822bu
+ pkgdesc = wireless lan driver for realtek devices like GigaBlue WLAN Stick 1200MBit Dual Band USB 3.0
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/EntropicEffect/rtl8822bu
+ arch = x86_64
+ license = unknown
+ source = https://github.com/EntropicEffect/rtl8822bu/archive/master.zip
+ md5sums = 70f004b6e99c32be2c185ffc89950162
+
+pkgname = rtl8822bu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..22fc59a2a618
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+master.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6d3aefb30e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Manuel Conzelmann <manolo89@online.de>
+pkgname=rtl8822bu
+pkgver=1
+pkgrel=1
+epoch=
+pkgdesc="wireless lan driver for realtek devices like GigaBlue WLAN Stick 1200MBit Dual Band USB 3.0"
+arch=(x86_64)
+url="https://github.com/EntropicEffect/rtl8822bu"
+license=('unknown')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/EntropicEffect/rtl8822bu/archive/master.zip")
+noextract=()
+md5sums=("70f004b6e99c32be2c185ffc89950162")
+validpgpkeys=()
+
+
+build() {
+ cd "$pkgname-master"
+ make
+}
+
+package() {
+ cd "$pkgname-master"
+ mv 88x2bu.ko $pkgname.ko
+ install -m 755 -d $pkgdir/usr/lib/modules/$(uname -r)/
+ install -p -m 644 $pkgname.ko $pkgdir/usr/lib/modules/$(uname -r)/
+# depmod -b $pkgdir -a
+}