summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-04-08 20:10:43 -0400
committerAdam Goldsmith2020-04-08 20:10:43 -0400
commitbed17ea5805ff9635e581c9be3349add51fe14c4 (patch)
tree9f63539ca48dbe2e426713f356fc9eca13afdfa4
parent0927121d8b9e86c224fb2c592a00ca3dfb56bce0 (diff)
downloadaur-bed17ea5805ff9635e581c9be3349add51fe14c4.tar.gz
Simply/standardize package, bump version to 0.9.1
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD47
2 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c03562c902b6..b05209299c93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,17 +3,14 @@ pkgbase = rtlamr
pkgver = 0.9.1
pkgrel = 2
url = https://github.com/bemasher/rtlamr
- arch = x86_64
- arch = i686
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ arch = any
license = AGPL3
- makedepends = git
depends = go
depends = rtl-sdr
options = !strip
options = !emptydirs
+ source = https://github.com/bemasher/rtlamr/archive/v0.9.1.tar.gz
+ md5sums = 8d47164413f6b6ca2aa188fb2a164f63
pkgname = rtlamr
diff --git a/PKGBUILD b/PKGBUILD
index 1c70fdef4c19..8f2aaeff3575 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,42 @@
-# Maintainer: bemasher <bemasher@gmail.com>
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+# Former Maintainer: bemasher <bemasher@gmail.com>
-pkgname=rtlamr-git
-pkgver=0.9.0
-pkgrel=1
+pkgname=rtlamr
+pkgver=0.9.1
+pkgrel=2
pkgdesc="An rtl-sdr receiver for Itron ERT compatible smart meters operating in the 900MHz ISM band."
-arch=('x86_64' 'i686')
-url="git+https://github.com:bemasher/rtlamr.git#tag=v0.9.1"
+arch=('any')
+url="https://github.com/bemasher/rtlamr"
+source=("https://github.com/bemasher/rtlamr/archive/v${pkgver}.tar.gz")
+md5sums=('8d47164413f6b6ca2aa188fb2a164f63')
license=('AGPL3')
depends=('go' 'rtl-sdr')
-makedepends=('git')
options=('!strip' '!emptydirs')
_gourl=github.com/bemasher/rtlamr
+prepare(){
+ mkdir -p gopath/src/$(dirname $_gourl)
+ ln -rTsf $pkgname-$pkgver gopath/src/$_gourl
+}
+
build() {
- GOPATH="$srcdir" go get -v ${_gourl}/...
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_gourl
+ go install \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v ./...
}
check() {
- GOPATH="$srcdir" go test -v ${_gourl}/...
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_gourl
+ go test ./...
}
-package() {
- mkdir -p "$pkgdir/usr/bin"
- install -p -m755 "$srcdir/bin/"* "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/$GOPATH"
- cp -Rv --preserve=timestamps "$srcdir/"{src,pkg} "$pkgdir/$GOPATH"
-
- # Package license (if available)
- for f in LICENSE COPYING LICENSE.* COPYING.*; do
- if [ -e "$srcdir/src/$_gourl/$f" ]; then
- install -Dm644 "$srcdir/src/$_gourl/$f" \
- "$pkgdir/usr/share/licenses/$pkgname/$f"
- fi
- done
+package() {
+ install -p -Dm755 gopath/bin/rtlamr "$pkgdir/usr/bin/rtlamr"
}
# vim:set ts=2 sw=2 et: