summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-04-08 20:42:18 -0400
committerAdam Goldsmith2020-04-08 20:42:18 -0400
commit4ea24e3314358637266910c13f5b21db72018175 (patch)
tree50bfdf6aa6f6bd389ca158f7647f04bc8d0a0ac5
downloadaur-4ea24e3314358637266910c13f5b21db72018175.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..135ef39b4d1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rtlamr-collect-git
+ pkgdesc = Data aggregation for rtlamr.
+ pkgver = r24.5905398
+ pkgrel = 1
+ url = https://github.com/bemasher/rtlamr-collect
+ arch = any
+ license = AGPL3
+ depends = go
+ depends = rtl-sdr
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/bemasher/rtlamr-collect.git
+ md5sums = SKIP
+
+pkgname = rtlamr-collect-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f7d258d09389
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+_pkgname=rtlamr-collect
+pkgname=rtlamr-collect-git
+pkgver=r24.5905398
+pkgrel=1
+pkgdesc=" Data aggregation for rtlamr."
+arch=('any')
+url="https://github.com/bemasher/rtlamr-collect"
+source=("git+https://github.com/bemasher/rtlamr-collect.git")
+md5sums=('SKIP')
+license=('AGPL3')
+depends=('go' 'rtl-sdr')
+options=('!strip' '!emptydirs')
+_gourl=github.com/bemasher/rtlamr-collect
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ mkdir -p gopath/src/${_gourl%/*}
+ ln -rTsf $_pkgname gopath/src/$_gourl
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_gourl
+ go install \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v ./...
+}
+
+check() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/$_gourl
+ go test ./...
+}
+
+
+package() {
+ install -p -Dm755 gopath/bin/rtlamr-collect "$pkgdir/usr/bin/rtlamr-collect"
+}
+
+# vim:set ts=2 sw=2 et: