summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-04-08 21:27:16 -0400
committerAdam Goldsmith2020-04-08 21:27:16 -0400
commit3a466a4e83b50934bf39a649c23859c878ed0aa8 (patch)
treefffda657d31e5ad803563f779ec7dc17197cb747
parentea23a96ae8da46cf0bf3b7baa3dc306fc2b16feb (diff)
downloadaur-3a466a4e83b50934bf39a649c23859c878ed0aa8.tar.gz
Switch to building from git
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD20
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b05209299c93..778e24543b07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
-pkgbase = rtlamr
+pkgbase = rtlamr-git
pkgdesc = An rtl-sdr receiver for Itron ERT compatible smart meters operating in the 900MHz ISM band.
- pkgver = 0.9.1
- pkgrel = 2
+ pkgver = v0.9.1.r16.g22749a72
+ pkgrel = 1
url = https://github.com/bemasher/rtlamr
arch = any
license = AGPL3
depends = go
depends = rtl-sdr
+ provides = rtlamr
+ conflicts = rtlamr
options = !strip
options = !emptydirs
- source = https://github.com/bemasher/rtlamr/archive/v0.9.1.tar.gz
- md5sums = 8d47164413f6b6ca2aa188fb2a164f63
+ source = git+https://github.com/bemasher/rtlamr.git
+ md5sums = SKIP
-pkgname = rtlamr
+pkgname = rtlamr-git
diff --git a/PKGBUILD b/PKGBUILD
index 14b37ea93cd2..07cc2e72e628 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
# Former Maintainer: bemasher <bemasher@gmail.com>
-pkgname=rtlamr
-pkgver=0.9.1
-pkgrel=2
+_pkgname=rtlamr
+pkgname=rtlamr-git
+pkgver=v0.9.1.r16.g22749a72
+pkgrel=1
pkgdesc="An rtl-sdr receiver for Itron ERT compatible smart meters operating in the 900MHz ISM band."
arch=('any')
url="https://github.com/bemasher/rtlamr"
-source=("https://github.com/bemasher/rtlamr/archive/v${pkgver}.tar.gz")
-md5sums=('8d47164413f6b6ca2aa188fb2a164f63')
+source=("git+https://github.com/bemasher/rtlamr.git")
+md5sums=('SKIP')
license=('AGPL3')
depends=('go' 'rtl-sdr')
+provides=('rtlamr')
+conflicts=('rtlamr')
options=('!strip' '!emptydirs')
_gourl=github.com/bemasher/rtlamr
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare(){
mkdir -p gopath/src/${_gourl%/*}
- ln -rTsf $pkgname-$pkgver gopath/src/$_gourl
+ ln -rTsf $_pkgname gopath/src/$_gourl
}
build() {