summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2017-03-17 19:19:08 +0100
committerxsmile2017-03-17 19:19:08 +0100
commit1e88a70b5570584ca4e88addb63cf2eefb8b461c (patch)
treeeac8d77cab66d48ac2f3aeb2287c939423f4586d
parent2b6a07140b45be05f35eabfbe55c16fc6e71eb26 (diff)
downloadaur-1e88a70b5570584ca4e88addb63cf2eefb8b461c.tar.gz
update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--command_pyroscope.cc2
-rw-r--r--ui_pyroscope.cc16
4 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4fbe2527f6..35d1f6f5c815 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 16 00:11:20 UTC 2017
+# Fri Mar 17 18:18:50 UTC 2017
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
- pkgver = 1.0.r26.gcb78fc3
+ pkgver = 1.0.r29.gad0cb71
pkgrel = 1
url = https://github.com/pyroscope/rtorrent-ps
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 57a16f1ba0f3..9aa53e9f1245 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rtorrent
pkgname=rtorrent-ps
_pkgver=0.9.6
-pkgver=1.0.r26.gcb78fc3
+pkgver=1.0.r29.gad0cb71
pkgrel=1
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
diff --git a/command_pyroscope.cc b/command_pyroscope.cc
index d7356b6d4127..182456e35eb7 100644
--- a/command_pyroscope.cc
+++ b/command_pyroscope.cc
@@ -243,7 +243,7 @@ std::string get_active_tracker_domain(torrent::Download* item) {
# VIEW: Show active and incomplete torrents (in view #9) and update every 20 seconds
# Items are grouped into complete, incomplete, and queued, in that order.
# Within each group, they're sorted by upload and then download speed.
- view_sort_current = active,"compare=----,d.is_open=,d.complete=,d.up.rate=,d.down.rate="
+ view.sort_current = active,"compare=----,d.is_open=,d.complete=,d.up.rate=,d.down.rate="
schedule = filter_active,12,20,"view.filter = active,\"or={d.up.rate=,d.down.rate=,not=$d.complete=}\" ;view.sort=active"
*/
torrent::Object apply_compare(rpc::target_type target, const torrent::Object::list_type& args) {
diff --git a/ui_pyroscope.cc b/ui_pyroscope.cc
index f430df654087..6454dc6d69fc 100644
--- a/ui_pyroscope.cc
+++ b/ui_pyroscope.cc
@@ -391,15 +391,15 @@ void ui_pyroscope_download_list_redraw_item(Window* window, display::Canvas* can
// better handling for trail of line 2 (ratio etc.)
int status_pos = 91;
- int ratio = rpc::call_command_value("d.get_ratio", rpc::make_target(*range.first));
+ int ratio = rpc::call_command_value("d.ratio", rpc::make_target(*range.first));
if (status_pos < canvas->width()) {
canvas->print(status_pos, pos+1, "R:%6.2f [%c%c] %-4.4s ",
float(ratio) / 1000.0,
- rpc::call_command_string("d.get_tied_to_file", rpc::make_target(*range.first)).empty() ? ' ' : 'T',
- (rpc::call_command_value("d.get_ignore_commands", rpc::make_target(*range.first)) == 0) ? ' ' : 'I',
+ rpc::call_command_string("d.tied_to_file", rpc::make_target(*range.first)).empty() ? ' ' : 'T',
+ (rpc::call_command_value("d.ignore_commands", rpc::make_target(*range.first)) == 0) ? ' ' : 'I',
(*range.first)->priority() == 2 ? "" :
- rpc::call_command_string("d.get_priority_str", rpc::make_target(*range.first)).c_str()
+ rpc::call_command_string("d.priority_str", rpc::make_target(*range.first)).c_str()
);
status_pos += 9 + 5 + 5;
}
@@ -410,7 +410,7 @@ void ui_pyroscope_download_list_redraw_item(Window* window, display::Canvas* can
if (!(*range.first)->bencode()->get_key("rtorrent").get_key_string("throttle_name").empty()) {
//item_status += "T=";
- item_status += rpc::call_command_string("d.get_throttle_name", rpc::make_target(*range.first)) + ' ';
+ item_status += rpc::call_command_string("d.throttle_name", rpc::make_target(*range.first)) + ' ';
}
// left-justifying this also overwrites any junk from the original display that we overwrite
@@ -530,7 +530,7 @@ bool ui_pyroscope_download_list_redraw(Window* window, display::Canvas* canvas,
core::Download* d = *range.first;
core::Download* item = d;
torrent::Tracker* tracker = get_active_tracker((*range.first)->download());
- int ratio = rpc::call_command_value("d.get_ratio", rpc::make_target(d));
+ int ratio = rpc::call_command_value("d.ratio", rpc::make_target(d));
bool has_msg = !d->message().empty();
bool has_alert = has_msg && d->message().find("Tried all trackers") == std::string::npos;
int offset = row_offset(view, range);
@@ -583,8 +583,8 @@ bool ui_pyroscope_download_list_redraw(Window* window, display::Canvas* canvas,
canvas->print(0, pos, "%s %s%s%s%s%s%s%s%s %s %s %s %s %s%s %s%s%s",
range.first == view->focus() ? "»" : " ",
item->is_open() ? item->is_active() ? "▹ " : "╍ " : "▪ ",
- rpc::call_command_string("d.get_tied_to_file", rpc::make_target(d)).empty() ? "  " : "⚯ ",
- rpc::call_command_value("d.get_ignore_commands", rpc::make_target(d)) == 0 ? "⚒ " : "◌ ",
+ rpc::call_command_string("d.tied_to_file", rpc::make_target(d)).empty() ? "  " : "⚯ ",
+ rpc::call_command_value("d.ignore_commands", rpc::make_target(d)) == 0 ? "⚒ " : "◌ ",
prios[d->priority() % 4],
d->is_done() ? "✔ " : progress_style == 0 ? progress_str : progress[progress_style][
item->file_list()->completed_chunks() * PROGRESS_STEPS