summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2017-04-28 23:53:16 +0000
committerxsmile2017-04-28 23:53:16 +0000
commit5da0b50ee5e0497d988f0bc8db268b3c6206a205 (patch)
treebce767237592faeb0ced99e82b9c0465a600e259
parentf5c0bd9fd68574b4fde920898ca16f8ee4514b7a (diff)
downloadaur-5da0b50ee5e0497d988f0bc8db268b3c6206a205.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--ps-fix-throttle-args_all.patch16
-rw-r--r--ui_pyroscope.cc2
4 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6de11306fa3e..f31d3e0c2d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 10 16:13:02 UTC 2017
+# Fri Apr 28 23:52:59 UTC 2017
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
- pkgver = 1.0.r55.g1f648ee
+ pkgver = 1.0.r57.gb49dfe3
pkgrel = 1
url = https://github.com/pyroscope/rtorrent-ps
arch = any
@@ -26,6 +26,7 @@ pkgbase = rtorrent-ps
source = ps-event-view_all.patch
source = ps-fix-double-slash-319_all.patch
source = ps-fix-sort-started-stopped-views_all.patch
+ source = ps-fix-throttle-args_all.patch
source = ps-handle-sighup-578_all.patch
source = ps-info-pane-xb-sizes_all.patch
source = ps-item-stats-human-sizes_all.patch
@@ -42,6 +43,7 @@ pkgbase = rtorrent-ps
md5sums = 56701bca42cc9b309637bf3f918ede12
md5sums = 22fae392c6e281dc438b39a5019e7e1b
md5sums = 3fd739c0d5a9442f0cdec9ed5a720eaa
+ md5sums = ab490d1d1df9c27f3cf624966f7f03f6
md5sums = 2137e16f8b881170fb92fb7a6c276193
md5sums = f1539d70c74e5c74d8a15d51675aa26c
md5sums = 2d34e8c86c1c6ed1354b55ca21819886
@@ -50,7 +52,7 @@ pkgbase = rtorrent-ps
md5sums = 7a88f8ab5d41242fdf1428de0e2ca182
md5sums = 26faff00b306b6ef276a7d9e6d964994
md5sums = bd04a0699b80c8042e1cf63a7e0e4222
- md5sums = eaed2a7fea74c6ac46cc4dc93d868074
+ md5sums = 21fd4b912ddabe32356eef0a4e87c681
md5sums = 1258acfc82c50a8f452ace87fef0b416
md5sums = 0a2bbaf74c7160ba33876dcc2f050f14
diff --git a/PKGBUILD b/PKGBUILD
index d40ec9b9cbf8..5aa1788dfd4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=rtorrent
pkgname=rtorrent-ps
_pkgver=0.9.6
-pkgver=1.0.r55.g1f648ee
+pkgver=1.0.r57.gb49dfe3
pkgrel=1
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
@@ -17,6 +17,7 @@ source=("https://github.com/rakshasa/$_pkgname/archive/$_pkgver.tar.gz"
'ps-event-view_all.patch'
'ps-fix-double-slash-319_all.patch'
'ps-fix-sort-started-stopped-views_all.patch'
+ 'ps-fix-throttle-args_all.patch'
'ps-handle-sighup-578_all.patch'
'ps-info-pane-xb-sizes_all.patch'
'ps-item-stats-human-sizes_all.patch'
@@ -33,6 +34,7 @@ md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'56701bca42cc9b309637bf3f918ede12'
'22fae392c6e281dc438b39a5019e7e1b'
'3fd739c0d5a9442f0cdec9ed5a720eaa'
+ 'ab490d1d1df9c27f3cf624966f7f03f6'
'2137e16f8b881170fb92fb7a6c276193'
'f1539d70c74e5c74d8a15d51675aa26c'
'2d34e8c86c1c6ed1354b55ca21819886'
@@ -41,7 +43,7 @@ md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'7a88f8ab5d41242fdf1428de0e2ca182'
'26faff00b306b6ef276a7d9e6d964994'
'bd04a0699b80c8042e1cf63a7e0e4222'
- 'eaed2a7fea74c6ac46cc4dc93d868074'
+ '21fd4b912ddabe32356eef0a4e87c681'
'1258acfc82c50a8f452ace87fef0b416'
'0a2bbaf74c7160ba33876dcc2f050f14')
diff --git a/ps-fix-throttle-args_all.patch b/ps-fix-throttle-args_all.patch
new file mode 100644
index 000000000000..eb92ab0b40c2
--- /dev/null
+++ b/ps-fix-throttle-args_all.patch
@@ -0,0 +1,16 @@
+--- orig-096/src/command_throttle.cc 2015-09-03 21:03:30.000000000 +0200
++++ rtorrent-0.9.6/src/command_throttle.cc 2017-04-27 05:17:31.000000000 +0200
+@@ -98,8 +98,10 @@
+
++ if (argItr == args.end())
++ throw torrent::input_error("Missing throttle name.");
+ const std::string& name = argItr->as_string();
+ if (name.empty() || name == "NULL")
+- throw torrent::input_error("Invalid throttle name.");
++ throw torrent::input_error("Invalid throttle name '" + name + "'.");
+
+- if ((++argItr)->as_string().empty())
+- return torrent::Object();
++ if (++argItr == args.end() || argItr->as_string().empty())
++ throw torrent::input_error("Missing throttle rate for '" + name + "'.");
+
diff --git a/ui_pyroscope.cc b/ui_pyroscope.cc
index ad02772efba7..cce7b375a9ed 100644
--- a/ui_pyroscope.cc
+++ b/ui_pyroscope.cc
@@ -507,7 +507,7 @@ int render_columns(bool headers, rpc::target_type target,
canvas->print(column, pos, " %s", u8_chop(text, header_len).c_str());
}
- // Advance posiiton
+ // Advance position
column += header_len + 1;
total += header_len + 1;
}