summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2020-07-09 00:18:00 +0200
committerxsmile2020-07-09 00:18:00 +0200
commitb0e1df4e04da2a4bbdc6c89dcf7dd97d3967ea6d (patch)
treefc3d5d1b683a447a9acb14d0af4d3205f2be1071
parent3c12c743c253ea142bdc9878e0875b3f34d43f1d (diff)
downloadaur-b0e1df4e04da2a4bbdc6c89dcf7dd97d3967ea6d.tar.gz
C++ compatibility fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--rt-cxx11-compatibility.patch10
3 files changed, 17 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9c71af92769..ad91c5fbb5bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rtorrent-ps
pkgdesc = Extended rTorrent distribution with UI enhancements, colorization, and some added features
pkgver = 1.1.r54.ga787dd9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pyroscope/rtorrent-ps
arch = any
license = GPL
@@ -37,6 +37,7 @@ pkgbase = rtorrent-ps
source = ps-view-filter-by_all.patch
source = pyroscope.patch
source = rt-base-cppunit-pkgconfig.patch
+ source = rt-cxx11-compatibility.patch
source = ui_pyroscope.cc
source = ui_pyroscope.h
source = ui_pyroscope.patch
@@ -66,6 +67,7 @@ pkgbase = rtorrent-ps
md5sums = 26faff00b306b6ef276a7d9e6d964994
md5sums = bd04a0699b80c8042e1cf63a7e0e4222
md5sums = d0a956f0eb4b53b66d83df2a8a4d16dc
+ md5sums = cf14decf96f7df8286007067387d4174
md5sums = 39e18c251a6049b60c2c28b1494eff2a
md5sums = 265c4ddeab5745a93c360a920a375dfe
md5sums = 0a2bbaf74c7160ba33876dcc2f050f14
diff --git a/PKGBUILD b/PKGBUILD
index e4ca2a0539c9..91de569e15dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=rtorrent
pkgname=rtorrent-ps
_pkgver=0.9.6
pkgver=1.1.r54.ga787dd9
-pkgrel=1
+pkgrel=2
pkgdesc='Extended rTorrent distribution with UI enhancements, colorization, and some added features'
url='https://github.com/pyroscope/rtorrent-ps'
license=('GPL')
@@ -38,6 +38,7 @@ source=("https://github.com/rakshasa/$_pkgname/archive/v$_pkgver.tar.gz"
'ps-view-filter-by_all.patch'
'pyroscope.patch'
'rt-base-cppunit-pkgconfig.patch'
+ 'rt-cxx11-compatibility.patch'
'ui_pyroscope.cc'
'ui_pyroscope.h'
'ui_pyroscope.patch')
@@ -67,6 +68,7 @@ md5sums=('b8b4009f95f8543244ae1d23b1810d7c'
'26faff00b306b6ef276a7d9e6d964994'
'bd04a0699b80c8042e1cf63a7e0e4222'
'd0a956f0eb4b53b66d83df2a8a4d16dc'
+ 'cf14decf96f7df8286007067387d4174'
'39e18c251a6049b60c2c28b1494eff2a'
'265c4ddeab5745a93c360a920a375dfe'
'0a2bbaf74c7160ba33876dcc2f050f14')
@@ -80,7 +82,7 @@ prepare() {
grep "AC_DEFINE.*API_VERSION" configure.ac >/dev/null || sed -i -e "s:\\(AC_DEFINE(HAVE_CONFIG_H.*\\):\1 AC_DEFINE(API_VERSION, 0, api version):" configure.ac
RT_BASE_PATCHES=("$srcdir"/rt-base-cppunit-pkgconfig.patch)
- RT_PATCHES=()
+ RT_PATCHES=("$srcdir"/rt-cxx11-compatibility.patch)
# Patch rTorrent
for corepatch in "${RT_BASE_PATCHES[@]}" \
diff --git a/rt-cxx11-compatibility.patch b/rt-cxx11-compatibility.patch
new file mode 100644
index 000000000000..809ebe3ee69b
--- /dev/null
+++ b/rt-cxx11-compatibility.patch
@@ -0,0 +1,10 @@
+--- a/src/display/window_file_list.cc
++++ b/src/display/window_file_list.cc
+@@ -36,6 +36,7 @@
+
+ #include "config.h"
+
++#include <locale>
+ #include <stdio.h>
+ #include <torrent/path.h>
+ #include <torrent/data/file.h>