summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 15:28:44 -0400
committerskydrome2015-06-01 15:28:44 -0400
commit6d6ead1c32a3902aa352e01b25e56eb0616911e8 (patch)
tree542738ee3f4c0ecbec338d3e89349045edeead86
downloadaur-6d6ead1c32a3902aa352e01b25e56eb0616911e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD103
-rw-r--r--pyroscope.install11
-rw-r--r--rtorrent.rc.sample68
4 files changed, 226 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..622f59547512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = rtorrent-pyro-git
+ pkgdesc = Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches
+ pkgver = 20150506
+ pkgrel = 1
+ url = https://github.com/pyroscope/rtorrent-ps
+ install = pyroscope.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cppunit
+ depends = libtorrent-pyro-git
+ depends = libsigc++
+ depends = ncurses
+ depends = curl
+ depends = xmlrpc-c
+ depends = gcc>=4.9.0
+ optdepends = ttf-dejavu: for utf8 glyphs
+ optdepends = ttf-everson-mono
+ optdepends = ttf-unifont
+ optdepends = ttf-andale-mono
+ provides = rtorrent
+ conflicts = rtorrent
+ conflicts = rtorrent-git
+ backup = usr/share/doc/rtorrent/rtorrent.rc.sample
+ source = git://github.com/rakshasa/rtorrent.git#commit=HEAD
+ source = rtorrent.rc.sample
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ps-ui_pyroscope_0.8.8.patch
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/pyroscope.patch
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ui_pyroscope.patch
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/command_pyroscope.cc
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ui_pyroscope.cc
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ui_pyroscope.h
+ md5sums = SKIP
+ md5sums = ea0073fba705a6b4124697e7defc6c5b
+ md5sums = 7a88f8ab5d41242fdf1428de0e2ca182
+ md5sums = bd04a0699b80c8042e1cf63a7e0e4222
+ md5sums = 0a2bbaf74c7160ba33876dcc2f050f14
+ md5sums = ba7634da91480021330e6fa8084b50d5
+ md5sums = 951b40c6d43caf0a3bffc5fffcc557d5
+ md5sums = 1258acfc82c50a8f452ace87fef0b416
+
+pkgname = rtorrent-pyro-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86e6855986f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,103 @@
+# Maintainer: skydrome <skydrome@i2pmail.org>
+# Contributor: skydrome <skydrome@i2pmail.org>
+
+# Compile a debug build?
+_debug=n
+
+# Compile from a specific commit?
+#_commit=cd029a6 #0.9.3
+#_commit=6a3234e #0.9.4
+_commit=HEAD
+
+pkgname=rtorrent-pyro-git
+pkgver=20150506
+pkgrel=1
+pkgdesc="Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches"
+url="https://github.com/pyroscope/rtorrent-ps"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('libtorrent-pyro-git' 'libsigc++' 'ncurses' 'curl' 'xmlrpc-c' 'gcc>=4.9.0')
+makedepends=('git' 'cppunit')
+optdepends=('ttf-dejavu: for utf8 glyphs'
+ 'ttf-everson-mono'
+ 'ttf-unifont'
+ 'ttf-andale-mono')
+conflicts=('rtorrent' 'rtorrent-git')
+provides=('rtorrent')
+install='pyroscope.install'
+backup=('usr/share/doc/rtorrent/rtorrent.rc.sample')
+
+[[ $_debug = 'n' ]] &&
+ _debug='--disable-debug' || options=(!strip)
+
+_url="https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches"
+source=("git://github.com/rakshasa/rtorrent.git#commit=$_commit"
+ "rtorrent.rc.sample"
+ #"http://libtorrent.rakshasa.no/downloads/xmlrpc2scgi.py"
+ "${_url}/ps-ui_pyroscope_0.8.8.patch"
+ "${_url}/pyroscope.patch"
+ "${_url}/ui_pyroscope.patch"
+ "${_url}/command_pyroscope.cc"
+ "${_url}/ui_pyroscope.cc"
+ "${_url}/ui_pyroscope.h")
+
+md5sums=('SKIP'
+ 'ea0073fba705a6b4124697e7defc6c5b'
+ '7a88f8ab5d41242fdf1428de0e2ca182'
+ 'bd04a0699b80c8042e1cf63a7e0e4222'
+ '0a2bbaf74c7160ba33876dcc2f050f14'
+ 'ba7634da91480021330e6fa8084b50d5'
+ '951b40c6d43caf0a3bffc5fffcc557d5'
+ '1258acfc82c50a8f452ace87fef0b416')
+
+pkgver() {
+ cd "$srcdir/rtorrent"
+ git log -1 --format="%cd" --date=short "$_commit" |tr -d -
+}
+
+prepare() {
+ cd "$srcdir/rtorrent"
+ #patch -Np1 -i "${startdir}/rtorrent.patch"
+
+ #sed -i configure.ac \
+ # -e "s:\\(AC_DEFINE(HAVE_CONFIG_H.*\\):\1\\nAC_DEFINE(RT_HEX_VERSION, 0x000904, for CPP if checks):"
+ sed -i src/ui/download_list.cc \
+ -e 's:rTorrent \" VERSION:rTorrent-PS " VERSION:'
+ sed -i doc/scripts/update_commands_0.9.sed \
+ -e "s:':\":g"
+ sed -i ../command_pyroscope.cc \
+ -e 's:view_filter:view.filter:' \
+ -e 's:RT_HEX_VERSION < 0x000904:RT_HEX_VERSION > 0x000904:'
+
+ for i in ${srcdir}/*.patch; do
+ sed -f doc/scripts/update_commands_0.9.sed -i "$i"
+ patch -uNp1 -i "$i"
+ done
+ for i in ${srcdir}/*.{cc,h}; do
+ sed -f doc/scripts/update_commands_0.9.sed -i "$i"
+ ln -s "$i" src
+ done
+
+ ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/rtorrent"
+ export CXXFLAGS+=" -std=c++11 -fno-strict-aliasing"
+ export libtorrent_LIBS="-L/usr/lib -ltorrent"
+
+ ./configure $_debug \
+ --prefix=/usr \
+ --with-xmlrpc-c
+
+ make
+}
+
+package() {
+ cd "$srcdir/rtorrent"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir"/rtorrent.rc.sample "${pkgdir}/usr/share/doc/rtorrent/rtorrent.rc.sample"
+ install -Dm644 doc/faq.xml "${pkgdir}/usr/share/doc/rtorrent/faq.xml"
+ install -Dm644 doc/old/rtorrent.1 "${pkgdir}/usr/share/man/man1/rtorrent.1"
+}
diff --git a/pyroscope.install b/pyroscope.install
new file mode 100644
index 000000000000..be4ed5027ac0
--- /dev/null
+++ b/pyroscope.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo " An updated rtorrent.rc file is installed to"
+ echo " /usr/share/doc/rtorrent/rtorrent.rc.sample"
+ echo " If you wish to use the pyrocore tools, you'll want to read"
+ echo " https://code.google.com/p/pyroscope/wiki/UserConfiguration"
+ echo
+}
+post_upgrade() {
+ post_install
+}
diff --git a/rtorrent.rc.sample b/rtorrent.rc.sample
new file mode 100644
index 000000000000..be19b67a6aa7
--- /dev/null
+++ b/rtorrent.rc.sample
@@ -0,0 +1,68 @@
+throttle.max_peers.normal.set = 50
+throttle.max_peers.seed.set = 50
+throttle.max_uploads.global.set = 250
+throttle.max_downloads.global.set = 250
+
+throttle.global_down.max_rate.set_kb = 5000
+throttle.global_up.max_rate.set_kb = 5000
+
+network.port_range.set = 36767-36767
+network.port_random.set = no
+network.http.ssl_verify_peer.set = no
+network.http.dns_cache_timeout.set = 25
+network.xmlrpc.size_limit.set = 2M
+
+file.prioritize_toc = 1
+pieces.hash.on_completion.set = no
+system.umask.set = 0027
+#system.file.allocate.set = yes
+dht.mode.set = auto
+protocol.pex.set = no
+protocol.encryption.set = allow_incoming,try_outgoing,enable_retry
+#protocol.encryption.set = allow_incoming,try_outgoing,require,require_RC4
+
+directory.default.set = ~/.rtorrent/downloads
+session.path.set = ~/.rtorrent/session
+network.scgi.open_local = ~/.rtorrent/rtorrent.sock
+#ipv4_filter.load = ~/.rtorrent/ipfilter, unwanted
+
+# LOGS - https://github.com/rakshasa/rtorrent/wiki/LOG_Logging
+#log.open_file = "rtorrent.log", (cat,/tmp/rtorrent.log.,(system.pid))
+#critical error warn notice info debug
+#log.add_output = "info", "rtorrent.log"
+#connection_* dht_*" peer_* rpc_* storage_* thread_* tracker_* torrent_*
+#log.add_output = "torrent_debug", "tracker.log"
+#log.add_output = "tracker_debug", "tracker.log"
+log.open_file = "rtorrent", ~/.rtorrent/logs/rtorrent.log
+log.add_output = "warn", "rtorrent"
+
+schedule = low_diskspace,5,60,close_low_diskspace=200M
+schedule = watch_directory,5,5,"load.start=~/.rtorrent/watch/*.torrent,d.delete_tied="
+
+#
+## PyroScope SETTINGS
+#
+
+method.insert = pyro.extended, value|const, 1
+method.insert = pyro.bin_dir, string|const, ~/bin/
+method.insert = pyro.rtorrent_rc, string|const|private, "$cat=~/.pyroscope/rtorrent-0.9.2.rc"
+import = $pyro.rtorrent_rc=
+
+# TORQUE: Daemon watchdog schedule
+# Must be activated by touching the "~/.pyroscope/run/pyrotorque" file!
+# Set the second argument to "-v" or "-q" to change log verbosity.
+schedule = pyro_watchdog,30,300,"pyro.watchdog=~/.pyroscope,"
+
+# UI/VIEW: Show active and incomplete torrents (in view #0) and update every 20 seconds
+# Items are grouped into complete, incomplete, and queued, in that order.
+# Within each group, they're sorted by download and then upload speed.
+branch=pyro.extended=,false=,"view.sort_current = active,greater=d.up.rate="
+branch=pyro.extended=,"view.sort_current = active,\"compare=----,d.is_open=,d.complete=,d.down.rate=,d.up.rate=\""
+schedule = filter_active,12,20,"view.filter = active,\"or={d.up.rate=,d.down.rate=,not=$d.complete=}\" ;view.sort=active"
+
+# Show traffic of the last hour
+network.history.depth.set = 112
+schedule = network_history_sampling,1,32, network.history.sample=
+method.insert = network.history.auto_scale.toggle, simple|private, "branch=network.history.auto_scale=,\"network.history.auto_scale.set=0\",\"network.history.auto_scale.set=1\""
+method.insert = network.history.auto_scale.ui_toggle, simple|private, "network.history.auto_scale.toggle= ;network.history.refresh="
+branch=pyro.extended=,"schedule = bind_auto_scale,0,0,\"ui.bind_key=download_list,=,network.history.auto_scale.ui_toggle=\""