summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2018-05-31 23:27:55 -0400
committerYour Name2018-05-31 23:27:55 -0400
commitc505b87d8f77717e2752b7b92d351b64cbfcc7c4 (patch)
treef2451d016f4d9e422263a7190c09fd89129f94fc
parent51f8012c341f46f194a0e385f159861836c75548 (diff)
downloadaur-c505b87d8f77717e2752b7b92d351b64cbfcc7c4.tar.gz
add math algorithm patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b970ed4168..a07575d1cbe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Apr 27 17:50:32 UTC 2018
+# Fri Jun 1 03:27:33 UTC 2018
pkgbase = rtorrent-pyro-git
pkgdesc = Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches
pkgver = 20180130
@@ -32,6 +32,8 @@ pkgbase = rtorrent-pyro-git
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ps-view-filter-by_all.patch
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ps-event-view_all.patch
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ps-fix-throttle-args_all.patch
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/backport_0.9.6_algorithm_median.patch
+ source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ps-silent-catch_all.patch
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/pyroscope.patch
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ui_pyroscope.patch
source = https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches/ui_pyroscope.cc
@@ -46,10 +48,12 @@ pkgbase = rtorrent-pyro-git
md5sums = 26faff00b306b6ef276a7d9e6d964994
md5sums = 56701bca42cc9b309637bf3f918ede12
md5sums = ab490d1d1df9c27f3cf624966f7f03f6
+ md5sums = b49903d3fa25a66c72db69570dfe8b47
+ md5sums = e3f367abe42d28168008f99a9bf0f1d6
md5sums = bd04a0699b80c8042e1cf63a7e0e4222
md5sums = 0a2bbaf74c7160ba33876dcc2f050f14
- md5sums = 21fd4b912ddabe32356eef0a4e87c681
- md5sums = 1258acfc82c50a8f452ace87fef0b416
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = rtorrent-pyro-git
diff --git a/PKGBUILD b/PKGBUILD
index c2d5a5a5ad4b..bc7d32e000b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,8 @@ source=("git://github.com/rakshasa/rtorrent.git#branch=$_branch"
"${_url}/ps-view-filter-by_all.patch"
"${_url}/ps-event-view_all.patch"
"${_url}/ps-fix-throttle-args_all.patch"
+ "${_url}/backport_0.9.6_algorithm_median.patch"
+ "${_url}/ps-silent-catch_all.patch"
"${_url}/pyroscope.patch"
"${_url}/ui_pyroscope.patch"
"${_url}/ui_pyroscope.cc"
@@ -57,10 +59,12 @@ md5sums=('SKIP'
'26faff00b306b6ef276a7d9e6d964994'
'56701bca42cc9b309637bf3f918ede12'
'ab490d1d1df9c27f3cf624966f7f03f6'
+ 'b49903d3fa25a66c72db69570dfe8b47'
+ 'e3f367abe42d28168008f99a9bf0f1d6'
'bd04a0699b80c8042e1cf63a7e0e4222'
'0a2bbaf74c7160ba33876dcc2f050f14'
- '21fd4b912ddabe32356eef0a4e87c681'
- '1258acfc82c50a8f452ace87fef0b416')
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/rtorrent"
@@ -94,7 +98,7 @@ build() {
cd "$srcdir/rtorrent"
#export CC=clang
#export CXX=clang++
- export CXXFLAGS+=" -fno-strict-aliasing -Wno-terminate"
+ export CXXFLAGS+=" -fno-strict-aliasing -faligned-new -Wno-terminate -Wno-class-memaccess"
export libtorrent_LIBS="-L/usr/lib -ltorrent"
./configure $_debug \