summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2016-04-08 04:11:31 -0400
committerskydrome2016-04-08 04:11:31 -0400
commitd93a46d66068c1318b487bfa93d94b8a6046a08d (patch)
tree7c269b53f89b9cd6f4f9ea5e3af68825641a6ccf
parent0f9373cc4f5ae9242cd46dab4dc21eb7a6a69712 (diff)
downloadaur-d93a46d66068c1318b487bfa93d94b8a6046a08d.tar.gz
fix building
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--fix_351.patch36
3 files changed, 8 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fb5ee507994..065d22f82def 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rtorrent-pyro-git
pkgdesc = Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches
- pkgver = 20151117
+ pkgver = 20160310
pkgrel = 1
url = https://github.com/pyroscope/rtorrent-ps
install = pyroscope.install
@@ -32,7 +32,7 @@ pkgbase = rtorrent-pyro-git
md5sums = 7a88f8ab5d41242fdf1428de0e2ca182
md5sums = bd04a0699b80c8042e1cf63a7e0e4222
md5sums = 0a2bbaf74c7160ba33876dcc2f050f14
- md5sums = b09d4632ba18f643b9f1ec8ccf1def9a
+ md5sums = 75b2f47edad1f27eb0aca495c6474089
md5sums = 23e215888c8c45cfc6b816b02f473c1b
md5sums = 1258acfc82c50a8f452ace87fef0b416
diff --git a/PKGBUILD b/PKGBUILD
index 43d1d5e6685f..7aa16ff86f62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,10 @@
_debug=n
# Compile from a specific commit?
-#_commit=6a3234e #0.9.4
-#_commit=3019261 #0.9.5
_commit=HEAD
pkgname=rtorrent-pyro-git
-pkgver=20151117
+pkgver=20160310
pkgrel=1
pkgdesc="Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches"
url="https://github.com/pyroscope/rtorrent-ps"
@@ -42,7 +40,7 @@ md5sums=('SKIP'
'7a88f8ab5d41242fdf1428de0e2ca182'
'bd04a0699b80c8042e1cf63a7e0e4222'
'0a2bbaf74c7160ba33876dcc2f050f14'
- 'b09d4632ba18f643b9f1ec8ccf1def9a'
+ '75b2f47edad1f27eb0aca495c6474089'
'23e215888c8c45cfc6b816b02f473c1b'
'1258acfc82c50a8f452ace87fef0b416')
@@ -55,6 +53,9 @@ prepare() {
cd "$srcdir/rtorrent"
#patch -Np1 -i "${startdir}/rtorrent.patch"
+ git revert -n --no-edit 30d8379391ad4cb3097d57aa56a488d061e68662
+ git revert -n --no-edit 1f5e4d37d5229b63963bb66e76c07ec3e359ecba
+
sed -i src/ui/download_list.cc \
-e 's:rTorrent \" VERSION:rTorrent-PS " VERSION:'
sed -i doc/scripts/update_commands_0.9.sed \
@@ -63,9 +64,6 @@ prepare() {
-e 's:view_filter:view.filter:' \
-e 's:RT_HEX_VERSION < 0x000904:RT_HEX_VERSION > 0x000904:'
- [[ $(grep "dl_rate" "src/core/download_store.cc") ]] &&
- patch -uNp1 -i "$startdir/fix_351.patch"
-
for i in ${srcdir}/*.patch; do
sed -f doc/scripts/update_commands_0.9.sed -i "$i"
msg "Patching $i"
@@ -73,7 +71,7 @@ prepare() {
done
for i in ${srcdir}/*.{cc,h}; do
sed -f doc/scripts/update_commands_0.9.sed -i "$i"
- ln -s "$i" src
+ ln -sf "$i" src
done
./autogen.sh
@@ -88,7 +86,6 @@ build() {
./configure $_debug \
--prefix=/usr \
--with-xmlrpc-c
-
make
}
diff --git a/fix_351.patch b/fix_351.patch
deleted file mode 100644
index 24f480dcf641..000000000000
--- a/fix_351.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 237c256ffafe5a178d6740e5c299b5a2a6c0b0aa Mon Sep 17 00:00:00 2001
-From: Micdu70 <Micdu70@users.noreply.github.com>
-Date: Tue, 17 Nov 2015 16:44:54 +0100
-Subject: [PATCH] Fix Pull Request #351
-
----
- src/core/download_factory.cc | 2 +-
- src/core/download_store.cc | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/core/download_factory.cc b/src/core/download_factory.cc
-index f19a481..b1bdd64 100644
---- a/src/core/download_factory.cc
-+++ b/src/core/download_factory.cc
-@@ -419,7 +419,7 @@ DownloadFactory::initialize_rtorrent(Download* download, torrent::Object* rtorre
- download->info()->mutable_up_rate()->set_total(rtorrent->get_key_value("total_uploaded"));
-
- if (rtorrent->has_key_value("total_downloaded"))
-- download->info()->mutable_dl_rate()->set_total(rtorrent->get_key_value("total_downloaded"));
-+ download->info()->mutable_down_rate()->set_total(rtorrent->get_key_value("total_downloaded"));
-
- if (rtorrent->has_key_value("chunks_done") && rtorrent->has_key_value("chunks_wanted"))
- download->download()->set_chunks_done(rtorrent->get_key_value("chunks_done"), rtorrent->get_key_value("chunks_wanted"));
-diff --git a/src/core/download_store.cc b/src/core/download_store.cc
-index a85dca9..536dba1 100644
---- a/src/core/download_store.cc
-+++ b/src/core/download_store.cc
-@@ -140,7 +140,7 @@ DownloadStore::save(Download* d, int flags) {
- rtorrent_base->insert_key("chunks_done", d->download()->file_list()->completed_chunks());
- rtorrent_base->insert_key("chunks_wanted", d->download()->data()->wanted_chunks());
- rtorrent_base->insert_key("total_uploaded", d->info()->up_rate()->total());
-- rtorrent_base->insert_key("total_downloaded", d->info()->dl_rate()->total());
-+ rtorrent_base->insert_key("total_downloaded", d->info()->down_rate()->total());
-
- // Don't save for completed torrents when we've cleared the uncertain_pieces.
- torrent::resume_save_progress(*d->download(), *resume_base);