summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Galakhov2020-07-05 17:19:43 +0200
committerAlexey Galakhov2020-07-05 17:25:42 +0200
commitca03aacfd0fcb4c952693bcdf9bd23cd5be47376 (patch)
treea5c15f76f24ddc854868996d535d96a7c3e04287
downloadaur-ca03aacfd0fcb4c952693bcdf9bd23cd5be47376.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19b6e5f948f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rtpmidid-git
+ pkgdesc = RTP MIDI User Space Driver Daemon
+ pkgver = r287.978e076
+ pkgrel = 1
+ url = https://github.com/davidmoreno/rtpmidid
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = alsa-lib
+ depends = fmt
+ depends = avahi
+ provides = rtpmidid
+ conflicts = rtpmidid
+ source = rtpmidid-git::git+https://github.com/davidmoreno/rtpmidid.git
+ sha256sums = SKIP
+
+pkgname = rtpmidid-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4732d767abdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alexey Galakhov <agalakhov@gmail.com>
+
+pkgname='rtpmidid-git'
+pkgver=r287.978e076
+pkgrel=1
+pkgdesc="RTP MIDI User Space Driver Daemon"
+arch=('i686' 'x86_64')
+url='https://github.com/davidmoreno/rtpmidid'
+license=('GPL3')
+depends=('alsa-lib' 'fmt' 'avahi')
+# aww, moved away from fltk
+makedepends=('git' 'cmake')
+provides=('rtpmidid')
+conflicts=('rtpmidid')
+source=('rtpmidid-git::git+https://github.com/davidmoreno/rtpmidid.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ #git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ make build
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir" install
+}
+