summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2013-11-15 13:41:32 +0100
committerPeter Hofmann2013-11-15 13:41:32 +0100
commit0215abacd6f479778c716c4a6bcdff9287b64458 (patch)
tree638c850b3276cc504313f97df7bf19564b5f4828
parentd372c3fbbc60f12e88ec0126010f018eb10631f6 (diff)
downloadaur-0215abacd6f479778c716c4a6bcdff9287b64458.tar.gz
rtspeccy: Overhaul
In particular, make $pkgver fit in the scheme of my other packages.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 679267ad93f4..6ee461b53ba8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rtspeccy-git
pkgdesc = Real time spectrum analyzer (audio)
- pkgver = 20120914.76
+ pkgver = 13.06
pkgrel = 1
url = http://www.uninformativ.de/projects/?q=rtspeccy
arch = i686
@@ -13,7 +13,7 @@ pkgbase = rtspeccy-git
depends = mesa
provides = rtspeccy
conflicts = rtspeccy
- source = rtspeccy::git+https://github.com/vain/rtspeccy.git
+ source = git://github.com/vain/rtspeccy.git
md5sums = SKIP
pkgname = rtspeccy-git
diff --git a/PKGBUILD b/PKGBUILD
index 8fec86d10219..2e313fa1498e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Army
+# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
+# Contributor: Army
_pkgname=rtspeccy
pkgname=$_pkgname-git
-pkgver=20120914.76
+pkgver=13.06
pkgrel=1
pkgdesc="Real time spectrum analyzer (audio)"
arch=('i686' 'x86_64')
@@ -11,18 +12,26 @@ depends=('glut' 'alsa-lib' 'fftw' 'mesa')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/vain/rtspeccy.git")
+source=(git://github.com/vain/rtspeccy.git)
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
+ git describe --always | sed 's|-|.|g; s|v||'
}
prepare() {
cd "$srcdir/$_pkgname"
+
# custom config
- if [ -e $SRCDEST/config.h ];then msg "using custom config.h";cp $SRCDEST/config.h .;else cp config.h.example config.h;fi
+ echo "$SRCDEST"
+ if [ -e "$SRCDEST"/config.h ]
+ then
+ msg "Using custom config.h"
+ cp "$SRCDEST"/config.h .
+ else
+ cp config.h.example config.h
+ fi
}
build() {