summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasilii Novikov2019-09-12 01:30:39 +0200
committerVasilii Novikov2019-09-12 01:30:39 +0200
commitcb915f304a93609db93bd0fb64cf160c890e857f (patch)
tree28f30631dd151d9534e5030d26e860a7bd8e5b6c
parent1d791749074c3fcea689a7ea8d3b259c78bb4399 (diff)
downloadaur-cb915f304a93609db93bd0fb64cf160c890e857f.tar.gz
add shellcheck depends and use unique source file name
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c1107c169b7..c0f6cd162f17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rua
pkgdesc = AUR helper in Rust providing control, review and jailed/offline build options
pkgver = 0.14.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vn971/rua
arch = x86_64
arch = i686
@@ -12,9 +12,10 @@ pkgbase = rua
depends = pacman
depends = xz
depends = openssl
+ optdepends = shellcheck: to check PKGBUILD scripts, taking care of special variables
optdepends = bubblewrap-suid: version of bubblewrap that works on linux-hardened kernel
optdepends = sudo: package installation can be done via sudo, if convenient
- source = https://github.com/vn971/rua/archive/0.14.13.tar.gz
+ source = rua-0.14.13.tar.gz::https://github.com/vn971/rua/archive/0.14.13.tar.gz
sha256sums = 84076175f24858f1984a7c4ac53c0f198a8d4773f79a4aec0d7b90ee2e9499f1
pkgname = rua
diff --git a/PKGBUILD b/PKGBUILD
index 4698b05f92e4..4d19598de2df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
pkgname=rua
pkgver=0.14.13
-pkgrel=1
+pkgrel=2
pkgdesc='AUR helper in Rust providing control, review and jailed/offline build options'
url='https://github.com/vn971/rua'
-source=("https://github.com/vn971/rua/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/vn971/rua/archive/${pkgver}.tar.gz")
arch=('x86_64' 'i686')
license=('GPL3')
makedepends=('cargo')
depends=('bubblewrap' 'git' 'pacman' 'xz' 'openssl')
optdepends=(
+ 'shellcheck: to check PKGBUILD scripts, taking care of special variables'
'bubblewrap-suid: version of bubblewrap that works on linux-hardened kernel'
'sudo: package installation can be done via sudo, if convenient'
)