summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2016-07-19 04:50:43 +0200
committerJan Holthuis2016-07-19 04:54:02 +0200
commit7e1fd5999e690ef43f1e6b4595cca4e098b768fa (patch)
tree657d9c9244e4c8e39dec00b9cccb12738efff354
downloadaur-7e1fd5999e690ef43f1e6b4595cca4e098b768fa.tar.gz
Inital version added
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--rubtexfonts2009.install18
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c29fdc94be0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jul 19 02:53:56 UTC 2016
+pkgbase = rubtexfonts2009
+ pkgdesc = Fonts for the Corporate Design of the Ruhr-University of Bochum. You need to download the files manually, using your LoginID from: https://noc.rub.de/~jobsanzl/latex/rubtexfonts-latest.tar.gz
+ pkgver = 0.0.20120318
+ pkgrel = 1
+ url = https://noc.rub.de/~jobsanzl/latex/
+ install = rubtexfonts2009.install
+ arch = any
+ license = unknown
+ depends = texlive-core
+ depends = texlive-fontsextra
+ source = rubtexfonts-latest.tar.gz::file://rubtexfonts-latest.tar.gz
+ sha256sums = c6a08662ee21f96a5ae1ea0b7d074e87e4bfa9476af2ef31429be4ab09bc479c
+
+pkgname = rubtexfonts2009
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6161f6bfc1f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jan Holthuis <holthuis.jan@gmail.com>
+
+pkgname=rubtexfonts2009
+pkgver=0.0.20120318
+pkgrel=1
+pkgdesc="Fonts for the Corporate Design of the Ruhr-University of Bochum. You need to download the files manually, using your LoginID from: https://noc.rub.de/~jobsanzl/latex/rubtexfonts-latest.tar.gz"
+arch=('any')
+url="https://noc.rub.de/~jobsanzl/latex/"
+license=('unknown')
+depends=('texlive-core' 'texlive-fontsextra')
+install=$pkgname.install
+source=("rubtexfonts-latest.tar.gz::file://rubtexfonts-latest.tar.gz")
+sha256sums=('c6a08662ee21f96a5ae1ea0b7d074e87e4bfa9476af2ef31429be4ab09bc479c')
+
+package() {
+ TEXMFDIST=$(kpsewhich -var-value=TEXMFDIST)
+ install -d -m755 "${pkgdir}/${TEXMFDIST}"
+
+ for subdir in "doc" "tex" "fonts" "source"; do
+ cp -r "${subdir}" "${pkgdir}/${TEXMFDIST}/${subdir}"
+ done
+
+ cd "${pkgdir}/${TEXMFDIST}"
+ find . -type d -exec chmod 755 {} \;
+ find . -type f -exec chmod 644 {} \;
+}
diff --git a/rubtexfonts2009.install b/rubtexfonts2009.install
new file mode 100644
index 000000000000..b04f543782b2
--- /dev/null
+++ b/rubtexfonts2009.install
@@ -0,0 +1,18 @@
+# arg 1: the new package version
+post_install() {
+ texconfig-sys rehash
+ updmap-sys --enable Map rub2009flama.map
+ updmap-sys --enable Map rub2009scala.map
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+post_remove() {
+ post_install
+}
+