summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Valentini2018-01-24 11:23:55 +0100
committerRoberto Valentini2018-01-24 11:23:55 +0100
commit7436772a90f54a9dc0bd94dd2c0ac3f4931cb549 (patch)
tree8d278205589379910c08157213eee6f34d241fd0
downloadaur-7436772a90f54a9dc0bd94dd2c0ac3f4931cb549.tar.gz
New activesupport v4.2.10 for occi
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4ca6935fdaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ruby-activesupport-4.2.10
+ pkgdesc = A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.
+ pkgver = 4.2.10
+ pkgrel = 1
+ url = http://rubyonrails.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = ruby>=1.9.3
+ depends = ruby-i18n>0.7
+ depends = ruby-minitest>5.1
+ depends = ruby-thread_safe>=0.3.4
+ depends = ruby-tzinfo>1.1
+ provides = ruby-activesupport=4.2.10
+ conflicts = ruby-activesupport
+ noextract = activesupport-4.2.10.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/activesupport-4.2.10.gem
+ sha256sums = 275b14e515eb8c924bafa734417ec053a57f177ae9d3369f753d6f4437922268
+
+pkgname = ruby-activesupport-4.2.10
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e2b120eda8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer Valantin <valantin89 [at] gmail [dot] com>
+
+_gemname=activesupport
+_pkgname=ruby-$_gemname
+pkgver=4.2.10
+pkgname=$_pkgname-$pkgver
+pkgrel=1
+pkgdesc='A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.'
+arch=(i686 x86_64)
+url='http://rubyonrails.org/'
+license=(MIT)
+depends=('ruby>=1.9.3'
+ 'ruby-i18n>0.7'
+ 'ruby-minitest>5.1'
+ 'ruby-thread_safe>=0.3.4'
+ 'ruby-tzinfo>1.1')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('275b14e515eb8c924bafa734417ec053a57f177ae9d3369f753d6f4437922268')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $_gemname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}