summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDDoSolitary2020-05-08 11:31:07 +0800
committerDDoSolitary2020-05-08 11:31:07 +0800
commitc62d34d0914186b0d6d1a96ec679397485e2f04d (patch)
tree910e4482a7b31382b92587a6c74cf1441e175a42
downloadaur-c62d34d0914186b0d6d1a96ec679397485e2f04d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a36bb9de2ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ruby-activesupport-5
+ pkgdesc = A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.
+ pkgver = 5.2.4.2
+ pkgrel = 1
+ url = http://rubyonrails.org
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-i18n
+ depends = ruby-tzinfo-1
+ depends = ruby-minitest
+ depends = ruby-concurrent
+ provides = ruby-activesupport
+ noextract = activesupport-5.2.4.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/activesupport-5.2.4.2.gem
+ sha256sums = 8c3ae3df5b08b49b6b5d9c5028da1a1e582f1243b7362dbb9736f65ede492378
+
+pkgname = ruby-activesupport-5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e28e0be5f88a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: DDoSolitary <DDoSolitary@gmail.com>
+
+_gemname=activesupport
+pkgname=ruby-$_gemname-5
+pkgver=5.2.4.2
+pkgrel=1
+pkgdesc='A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.'
+arch=(any)
+url='http://rubyonrails.org'
+license=(MIT)
+depends=(ruby ruby-i18n ruby-tzinfo-1 ruby-minitest ruby-concurrent)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('8c3ae3df5b08b49b6b5d9c5028da1a1e582f1243b7362dbb9736f65ede492378')
+provides=('ruby-activesupport')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/MIT-LICENSE" "$pkgdir/usr/share/licenses/$pkgname/MIT-LICENSE"
+}