summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2016-01-01 00:57:58 +0100
committerSven Schneider2016-01-01 00:57:58 +0100
commitd3b55e17f4bf01a85029ac2140ecacf42093e780 (patch)
tree89c7fdb6f40f666dd710eb05c9cb3da769764d78
parent18f3bc91cd3fd9e0266cbb01d181ba2c3ab3e70b (diff)
downloadaur-d3b55e17f4bf01a85029ac2140ecacf42093e780.tar.gz
update to 1.9.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a26cc0517331..80ab3e3e1811 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Dec 31 23:52:52 UTC 2015
pkgbase = ruby-autobuild
- pkgdesc = Collection of classes to handle build systems (CMake, autotools, ...) and import mechanisms (tarballs, CVS, SVN, git, ...).
- pkgver = 1.7.2
+ pkgdesc = Library to handle build systems and import mechanisms
+ pkgver = 1.9.3
pkgrel = 1
- url = http://rock-robotics.org/stable/documentation/autoproj/
+ url = http://rock-robotics.org/stable/documentation/autoproj
arch = any
- license = GPL
+ license = BSD
makedepends = rubygems
depends = ruby
+ depends = ruby-utilrb-2
depends = ruby-highline
- depends = ruby-utilrb
- noextract = autobuild-1.7.2.gem
- source = http://gems.rubyforge.org/gems/autobuild-1.7.2.gem
- md5sums = f990fd9034de97ac6f9dc3b32734b197
+ noextract = autobuild-1.9.3.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/autobuild-1.9.3.gem
+ sha512sums = 3097c1da01f14dd3f90d2da615771822d32d91f3b9c5d05b64f3df392496fcbd5a3fbd613903dbbd5327f451e82b8bf8036c4a899d5cdfdce34185849afe1bc1
pkgname = ruby-autobuild
diff --git a/PKGBUILD b/PKGBUILD
index a4303df96996..e7e181cfb9f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,23 @@
-# Maintainer: Sven Schneider <youremail@domain.com>
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
_gemname=autobuild
pkgname=ruby-$_gemname
-pkgver=1.7.2
+pkgver=1.9.3
pkgrel=1
-pkgdesc="Collection of classes to handle build systems (CMake, autotools, ...) and import mechanisms (tarballs, CVS, SVN, git, ...)."
-arch=(any)
-url="http://rock-robotics.org/stable/documentation/autoproj/"
-license=('GPL')
-depends=(ruby ruby-highline ruby-utilrb)
-makedepends=(rubygems)
-source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
+pkgdesc="Library to handle build systems and import mechanisms"
+arch=('any')
+url="http://rock-robotics.org/stable/documentation/autoproj"
+license=('BSD')
+depends=('ruby' 'ruby-utilrb-2' 'ruby-highline')
+makedepends=('rubygems')
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-md5sums=(f990fd9034de97ac6f9dc3b32734b197)
+sha512sums=('3097c1da01f14dd3f90d2da615771822d32d91f3b9c5d05b64f3df392496fcbd5a3fbd613903dbbd5327f451e82b8bf8036c4a899d5cdfdce34185849afe1bc1')
package() {
- cd "$srcdir"
- # _gemdir is defined inside package() because if ruby[gems] is not installed on
- # the system, makepkg will exit with an error when sourcing the PKGBUILD.
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
-
- gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
- "$_gemname-$pkgver.gem"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
}
-
-# vim:set ts=2 sw=2 et: