summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-07-14 15:22:02 +0200
committerTimothy Redaelli2015-07-14 15:22:02 +0200
commitd20c70366e5fc579c517f8be530fa7d561c81754 (patch)
tree09d1162161d5230fcd8c74398dd2fe3afdecf97b
downloadaur-d20c70366e5fc579c517f8be530fa7d561c81754.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f14e114f6da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-bindata
+ pkgdesc = A declarative way to read and write binary file formats
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = http://bindata.rubyforge.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = rubygems
+ depends = ruby
+ noextract = bindata-1.4.3.gem
+ source = http://gems.rubyforge.org/gems/bindata-1.4.3.gem
+ sha256sums = 1004d10a8a194bc181cc836220939379ae18e797e8756e01415ac8ae80c8f5a5
+
+pkgname = ruby-bindata
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..045b4dd53348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+
+_gemname=bindata
+pkgname=ruby-$_gemname
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="A declarative way to read and write binary file formats"
+arch=('i686' 'x86_64')
+url="http://bindata.rubyforge.org"
+license=('GPL2')
+depends=('ruby')
+makedepends=('rubygems')
+source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('1004d10a8a194bc181cc836220939379ae18e797e8756e01415ac8ae80c8f5a5')
+
+package() {
+ cd $srcdir
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies -i "$pkgdir$_gemdir" $_gemname-$pkgver.gem
+}