summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-14 05:03:32 +0300
committerArtem Vorotnikov2015-06-14 05:03:32 +0300
commitcdb0797eff6fa229d7a6c70e7e091f054c7cd04c (patch)
tree97efaec5c539d0505cebcd07f2b93292c6748b87
downloadaur-cdb0797eff6fa229d7a6c70e7e091f054c7cd04c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db62d746e32b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-childprocess
+ pkgdesc = This gem aims at being a simple and reliable solution for controlling external programs running in the background on any Ruby / OS combination.
+ pkgver = 0.5.6
+ pkgrel = 1
+ url = http://github.com/jarib/childprocess
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-ffi
+ noextract = childprocess-0.5.6.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/childprocess-0.5.6.gem
+ sha512sums = b4e7c7095028d03002d54d6cf05c43fb6792a3284cb879d1a29090219b6eea9e945b06f9906c308f4f1c73bb79bece178c67c17da22a1a78ad30b8f96b67df04
+
+pkgname = ruby-childprocess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b88c1c70a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+_gemname=childprocess
+pkgname=ruby-$_gemname
+pkgver=0.5.6
+pkgrel=1
+pkgdesc='This gem aims at being a simple and reliable solution for controlling external programs running in the background on any Ruby / OS combination.'
+arch=(any)
+url='http://github.com/jarib/childprocess'
+license=(MIT)
+depends=(ruby ruby-ffi)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha512sums=('b4e7c7095028d03002d54d6cf05c43fb6792a3284cb879d1a29090219b6eea9e945b06f9906c308f4f1c73bb79bece178c67c17da22a1a78ad30b8f96b67df04')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}