summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-07-06 20:21:03 -0400
committerMario Finelli2015-07-06 20:21:03 -0400
commit607b1994f2a9eb22ea62a89cab0cfe39fb8c5bc3 (patch)
tree07af5a32b45741c16105091169b01a6a833c7080
downloadaur-607b1994f2a9eb22ea62a89cab0cfe39fb8c5bc3.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..854fbac4a16e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-choice
+ pkgdesc = Define and parse command line options with a friendly DSL.
+ pkgver = 0.2.0
+ pkgrel = 2
+ url = https://github.com/defunkt/choice
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = choice-0.2.0.gem
+ source = https://rubygems.org/downloads/choice-0.2.0.gem
+ sha256sums = a19617f7dfd4921b38a85d0616446620de685a113ec6d1ecc85bdb67bf38c974
+
+pkgname = ruby-choice
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fff9a4ca856f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Christopher Eby <kreed at kreed dot org>
+
+_gemname=choice
+pkgname=ruby-$_gemname
+pkgver=0.2.0
+pkgrel=2
+pkgdesc="Define and parse command line options with a friendly DSL."
+arch=(any)
+url="https://github.com/defunkt/choice"
+license=('MIT')
+depends=('ruby')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('a19617f7dfd4921b38a85d0616446620de685a113ec6d1ecc85bdb67bf38c974')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+}