summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2015-06-14 02:54:49 +0300
committerArtem Vorotnikov2015-06-14 02:54:49 +0300
commitb623c7cce5b44891d93a359aafd50b74975ca750 (patch)
tree408e0b3020b0f64f728e88fa6f3e8cd4afda2867
downloadaur-b623c7cce5b44891d93a359aafd50b74975ca750.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d46996046479
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-coffee-script-source
+ pkgdesc = The CoffeeScript Compiler
+ pkgver = 1.9.1.1
+ pkgrel = 1
+ url = http://jashkenas.github.com/coffee-script/
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = coffee-script-source-1.9.1.1.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/coffee-script-source-1.9.1.1.gem
+ sha512sums = 4d37f65b2e5e4aeb8692d7022a2d048ae49520cc247fcb3da7fabb620270982d537d68b17619842f357ed00bcb297e9709362b3a56ad8325a7dd9a820956cdcc
+
+pkgname = ruby-coffee-script-source
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b630522b1d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+_gemname=coffee-script-source
+pkgname=ruby-$_gemname
+pkgver=1.9.1.1
+pkgrel=1
+pkgdesc='The CoffeeScript Compiler'
+arch=(any)
+url='http://jashkenas.github.com/coffee-script/'
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha512sums=('4d37f65b2e5e4aeb8692d7022a2d048ae49520cc247fcb3da7fabb620270982d537d68b17619842f357ed00bcb297e9709362b3a56ad8325a7dd9a820956cdcc')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}