summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Maunier2018-12-14 16:07:39 +0100
committerFlorian Maunier2018-12-14 16:07:39 +0100
commitb0d9122b0090628ab5b051a341cf7c79514d43c3 (patch)
tree24a860c79ba25d492e28da07fd245e4cbb513dc6
downloadaur-b0d9122b0090628ab5b051a341cf7c79514d43c3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48d1e76d72cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ruby-colorls
+ pkgdesc = A Ruby CLI gem that beautifies the terminal's ls command, with color and font-awesome icons.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/athityakumar/colorls
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-clocale
+ depends = ruby-filesize
+ depends = ruby-manpages
+ depends = ruby-rainbow
+ noextract = colorls-1.1.1.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/colorls-1.1.1.gem
+ sha1sums = 9c62ae0e3cc4b81665740376e228b3944a187034
+
+pkgname = ruby-colorls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8956c5caf0f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
+
+_gemname=colorls
+pkgname=ruby-$_gemname
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='A Ruby CLI gem that beautifies the terminal'\''s ls command, with color and font-awesome icons.'
+arch=(any)
+url='https://github.com/athityakumar/colorls'
+license=(MIT)
+depends=(ruby ruby-clocale ruby-filesize ruby-manpages ruby-rainbow)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('9c62ae0e3cc4b81665740376e228b3944a187034')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+}