summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2015-06-09 11:13:32 +0200
committerMassimiliano Torromeo2015-06-09 11:13:32 +0200
commit0380233e4912647d623e68c5abf86fb6699f0900 (patch)
treee9c582f329d6db1694f940111eb578103ac8c963
downloadaur-0380233e4912647d623e68c5abf86fb6699f0900.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--Gemfile6
-rw-r--r--Gemfile.lock25
-rw-r--r--PKGBUILD41
-rw-r--r--bundler.patch22
5 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..900bff7c431b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ruby-compass
+ pkgdesc = A Real Stylesheet Framework
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = http://compass-style.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ depends = ruby-bundler
+ noextract = compass-1.0.3.gem
+ source = http://gems.rubyforge.org/gems/compass-1.0.3.gem
+ source = Gemfile
+ source = Gemfile.lock
+ source = bundler.patch
+ sha256sums = 4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151
+ sha256sums = 2cd0895f4e54b14edd9eb599220900e6cf43a1f57754bfbd790b9a2ec2aab6b0
+ sha256sums = 65918ac12b7b0f97daea52bdb030cb3910b9a344f869173fb2cbbcdf9b9275e2
+ sha256sums = fbee7344a019d115caddf00667e9473a4e82f2999bdff9c04ccc4aa31b979d72
+
+pkgname = ruby-compass
+
diff --git a/Gemfile b/Gemfile
new file mode 100644
index 000000000000..697711e502bf
--- /dev/null
+++ b/Gemfile
@@ -0,0 +1,6 @@
+source "https://rubygems.org"
+gem 'chunky_png', "~> 1.2"
+gem 'compass-core', "~> 1.0.2"
+gem 'compass-import-once', "~> 1.0.5"
+gem 'rb-fsevent', ">= 0.9.3"
+gem 'rb-inotify', ">= 0.9"
diff --git a/Gemfile.lock b/Gemfile.lock
new file mode 100644
index 000000000000..60af975bc6a8
--- /dev/null
+++ b/Gemfile.lock
@@ -0,0 +1,25 @@
+GEM
+ remote: https://rubygems.org/
+ specs:
+ chunky_png (1.3.4)
+ compass-core (1.0.3)
+ multi_json (~> 1.0)
+ sass (>= 3.3.0, < 3.5)
+ compass-import-once (1.0.5)
+ sass (>= 3.2, < 3.5)
+ ffi (1.9.8)
+ multi_json (1.11.0)
+ rb-fsevent (0.9.4)
+ rb-inotify (0.9.5)
+ ffi (>= 0.5.0)
+ sass (3.4.13)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ chunky_png (~> 1.2)
+ compass-core (~> 1.0.2)
+ compass-import-once (~> 1.0.5)
+ rb-fsevent (>= 0.9.3)
+ rb-inotify (>= 0.9)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..567e33be9597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Aliaksiej ArtamonaĆ­ <aliaksiej.artamonau@gmail.com>
+
+pkgname=ruby-compass
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A Real Stylesheet Framework"
+arch=(i686 x86_64)
+url="http://compass-style.org"
+license=("MIT")
+depends=("ruby" "ruby-bundler")
+makedepends=("rubygems")
+source=("http://gems.rubyforge.org/gems/compass-${pkgver}.gem"
+ "Gemfile"
+ "Gemfile.lock"
+ "bundler.patch")
+noextract=("compass-$pkgver.gem")
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir$_gemdir" -n "$pkgdir"/usr/bin compass-$pkgver.gem
+ rm "$pkgdir$_gemdir"/cache/compass-$pkgver.gem
+
+ install -d -m755 "$pkgdir"/usr/share/licenses/$pkgname
+ install -D "$pkgdir$_gemdir"/gems/compass-$pkgver/LICENSE.markdown \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ cd "$pkgdir$_gemdir"/gems/compass-$pkgver
+ cp "$srcdir"/Gemfile{,.lock} .
+ bundle install --deployment
+ patch -p1 -i "$srcdir"/bundler.patch
+
+ rm "$pkgdir"/usr/bin/compass
+ ln -s "$_gemdir"/gems/compass-$pkgver/bin/compass "$pkgdir"/usr/bin/compass
+}
+
+sha256sums=('4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151'
+ '2cd0895f4e54b14edd9eb599220900e6cf43a1f57754bfbd790b9a2ec2aab6b0'
+ '65918ac12b7b0f97daea52bdb030cb3910b9a344f869173fb2cbbcdf9b9275e2'
+ 'fbee7344a019d115caddf00667e9473a4e82f2999bdff9c04ccc4aa31b979d72')
diff --git a/bundler.patch b/bundler.patch
new file mode 100644
index 000000000000..cb23ecce50f0
--- /dev/null
+++ b/bundler.patch
@@ -0,0 +1,22 @@
+--- a/bin/compass 2014-03-19 14:28:01.666995210 +0100
++++ b/bin/compass 2014-03-19 14:27:04.653662867 +0100
+@@ -1,6 +1,10 @@
+ #!/usr/bin/env ruby
+ # The compass command line utility
+
++ENV["BUNDLE_GEMFILE"] = File.expand_path('../../Gemfile', File.realpath(__FILE__))
++require 'rubygems'
++require 'bundler/setup'
++
+ # This allows compass to run easily from a git checkout without install.
+ def fallback_load_path(path)
+ retried = false
+@@ -16,7 +20,7 @@
+ end
+ end
+
+-fallback_load_path(File.join(File.dirname(__FILE__), '..', 'lib')) do
++fallback_load_path(File.join(File.dirname(File.realpath(__FILE__)), '..', 'lib')) do
+ require 'compass'
+ require 'compass/exec'
+ end