summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Brill2017-05-09 21:38:58 +0200
committerChristoph Brill2017-05-09 21:38:58 +0200
commitee80a0385ac7b881928f65a6bbe51571b0cfb7aa (patch)
tree1753af1ada93269c533d0e2421f6adf6a6638054
parenta855387221ba80cb889e43e4a7e21c944a5a8fae (diff)
downloadaur-ee80a0385ac7b881928f65a6bbe51571b0cfb7aa.tar.gz
Add breakpoint and susy as Gemfile dependencies
Otherwise the following error occurs: LoadError on line ["179"] of /usr/lib/ruby/gems/2.4.0/gems/compass-1.0.3/vendor/bundle/ruby/2.4.0/gems/ compass-core-1.0.3/lib/compass/configuration/data.rb: cannot load such file -- susy
-rw-r--r--.SRCINFO6
-rw-r--r--Gemfile2
-rw-r--r--Gemfile.lock23
-rw-r--r--PKGBUILD6
4 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 666e59bab69f..1fd934fce6d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ruby-compass
pkgdesc = A Real Stylesheet Framework
pkgver = 1.0.3
- pkgrel = 3
+ pkgrel = 4
url = http://compass-style.org
arch = i686
arch = x86_64
@@ -15,8 +15,8 @@ pkgbase = ruby-compass
source = Gemfile.lock
source = bundler.patch
sha256sums = 4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151
- sha256sums = 2cd0895f4e54b14edd9eb599220900e6cf43a1f57754bfbd790b9a2ec2aab6b0
- sha256sums = ae49ad8b7b1da183627d12bd6454a59bf023300431a1ce1433c160e0fb2db308
+ sha256sums = 752e400aa7ee7acef419d7f41134a05d9ea3de99eff065a61cb1fa0b34a65ad7
+ sha256sums = 1bf83163d7a7394c49f030065cdc98fcba1d707716854fc2d6e1a17eba916a3d
sha256sums = fbee7344a019d115caddf00667e9473a4e82f2999bdff9c04ccc4aa31b979d72
pkgname = ruby-compass
diff --git a/Gemfile b/Gemfile
index 697711e502bf..f18d7b568e54 100644
--- a/Gemfile
+++ b/Gemfile
@@ -4,3 +4,5 @@ gem 'compass-core', "~> 1.0.2"
gem 'compass-import-once', "~> 1.0.5"
gem 'rb-fsevent', ">= 0.9.3"
gem 'rb-inotify', ">= 0.9"
+gem 'breakpoint', ">= 2.5.0"
+gem 'susy', ">= 2.2.6"
diff --git a/Gemfile.lock b/Gemfile.lock
index 1f2237c0ad87..ecb998df7185 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -1,28 +1,37 @@
GEM
remote: https://rubygems.org/
specs:
- chunky_png (1.3.4)
+ breakpoint (2.7.1)
+ sass (~> 3.3)
+ sassy-maps (< 1.0.0)
+ chunky_png (1.3.8)
compass-core (1.0.3)
multi_json (~> 1.0)
sass (>= 3.3.0, < 3.5)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
- ffi (1.9.10)
- multi_json (1.11.2)
- rb-fsevent (0.9.6)
- rb-inotify (0.9.5)
+ ffi (1.9.18)
+ multi_json (1.12.1)
+ rb-fsevent (0.9.8)
+ rb-inotify (0.9.8)
ffi (>= 0.5.0)
- sass (3.4.19)
+ sass (3.4.23)
+ sassy-maps (0.4.0)
+ sass (~> 3.3)
+ susy (2.2.12)
+ sass (>= 3.3.0, < 3.5)
PLATFORMS
ruby
DEPENDENCIES
+ breakpoint (>= 2.5.0)
chunky_png (~> 1.2)
compass-core (~> 1.0.2)
compass-import-once (~> 1.0.5)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
+ susy (>= 2.2.6)
BUNDLED WITH
- 1.10.6
+ 1.14.6
diff --git a/PKGBUILD b/PKGBUILD
index 35a14d2d30a4..c45551fdc1d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-compass
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="A Real Stylesheet Framework"
arch=(i686 x86_64)
url="http://compass-style.org"
@@ -36,6 +36,6 @@ package() {
}
sha256sums=('4c7884dc5349d59011fd6c5736a0404008d5609235037741feac9c8ff840d151'
- '2cd0895f4e54b14edd9eb599220900e6cf43a1f57754bfbd790b9a2ec2aab6b0'
- 'f63fe96ada4ab8121f56c31c926fad0abfda0f13862306e84a73fd4090e6b8d0'
+ '752e400aa7ee7acef419d7f41134a05d9ea3de99eff065a61cb1fa0b34a65ad7'
+ '1bf83163d7a7394c49f030065cdc98fcba1d707716854fc2d6e1a17eba916a3d'
'fbee7344a019d115caddf00667e9473a4e82f2999bdff9c04ccc4aa31b979d72')