summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2018-02-14 09:29:19 +0100
committerPhilipp Wolfer2018-02-14 09:29:19 +0100
commitbe38b426576951b1543b2fb9347608b5e96d2435 (patch)
treeca55dc409a1bd3f6b70603744c3c3b677f534fd8
parentbc5c07ffa71ed6c738ca56473762b0a7e2aa9aa1 (diff)
downloadaur-be38b426576951b1543b2fb9347608b5e96d2435.tar.gz
Fixed gemdir detection for Ruby 2.5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98c132c7c6ed..66ef95c3e42e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Feb 17 08:21:04 UTC 2017
pkgbase = ruby-discid
pkgdesc = Ruby bindings for the MusicBrainz DiscID library libdiscid.
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/phw/ruby-discid
arch = any
license = LGPL3
diff --git a/PKGBUILD b/PKGBUILD
index fcfe98e27fae..d6cafe9cb12a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_gemname=discid
pkgname=ruby-$_gemname
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Ruby bindings for the MusicBrainz DiscID library libdiscid."
arch=(any)
url="https://github.com/phw/ruby-discid"
@@ -17,7 +17,7 @@ package() {
cd "$srcdir"
# _gemdir is defined inside package() because if ruby[gems] is not installed on
# the system, makepkg will exit with an error when sourcing the PKGBUILD.
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _gemdir="$(ruby -rrubygems -e'puts Gem.default_dir')"
gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" \
-n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"