summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2015-08-27 11:15:07 +0200
committerPhilipp Wolfer2015-08-27 11:15:07 +0200
commitcce3b6c34519e4231e1c214f4d1e82e0ea347796 (patch)
treee7cf40537e397140f572fd38febdd705b8bdb209
parentcea16f82382b645b9443d0ebb153504008f67151 (diff)
downloadaur-cce3b6c34519e4231e1c214f4d1e82e0ea347796.tar.gz
New upstream release, install LICENSE file
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf1cef0627f3..e00c610c3b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ruby-discid
pkgdesc = Ruby bindings for the MusicBrainz DiscID library libdiscid.
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = https://github.com/phw/ruby-discid
arch = any
@@ -9,9 +9,9 @@ pkgbase = ruby-discid
depends = ruby
depends = ruby-ffi
depends = libdiscid
- noextract = discid-1.1.0.gem
- source = http://gems.rubyforge.org/gems/discid-1.1.0.gem
- sha256sums = 8c8c3c7bd14961f6f5a11e1ed81e812e1a6aec2459b4a77c34a78ebf05aa5a4a
+ noextract = discid-1.1.1.gem
+ source = http://gems.rubyforge.org/gems/discid-1.1.1.gem
+ sha256sums = e5ea57917ff4c761b5e148236e9e75e0d96caaa29c68cb289e2912b2cbea1a53
pkgname = ruby-discid
diff --git a/PKGBUILD b/PKGBUILD
index 7f7bddbf1363..19e20b6170b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
_gemname=discid
pkgname=ruby-$_gemname
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc="Ruby bindings for the MusicBrainz DiscID library libdiscid."
arch=(any)
@@ -11,7 +11,7 @@ depends=(ruby ruby-ffi libdiscid) # Full dependency information is available in
makedepends=(rubygems)
source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha256sums=(8c8c3c7bd14961f6f5a11e1ed81e812e1a6aec2459b4a77c34a78ebf05aa5a4a)
+sha256sums=(e5ea57917ff4c761b5e148236e9e75e0d96caaa29c68cb289e2912b2cbea1a53)
package() {
cd "$srcdir"
@@ -19,8 +19,10 @@ package() {
# the system, makepkg will exit with an error when sourcing the PKGBUILD.
local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
- gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
- "$_gemname-$pkgver.gem"
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" \
+ -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+ rm "$pkgdir$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: