summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Wolfer2015-06-09 11:11:49 +0200
committerPhilipp Wolfer2015-06-09 11:11:49 +0200
commiteb4840fda3bacc124d51eb1716ea99e664cc4cc4 (patch)
treef04e28a71852859ef97eb3a437b7d6ba54bed02f
downloadaur-eb4840fda3bacc124d51eb1716ea99e664cc4cc4.tar.gz
Migrated latest version from aur3
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD26
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d71a4bdba1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-discid
+ pkgdesc = Ruby bindings for the MusicBrainz DiscID library libdiscid.
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = https://github.com/phw/ruby-discid
+ arch = any
+ license = LGPL3
+ makedepends = rubygems
+ depends = ruby
+ depends = ruby-ffi
+ depends = libdiscid
+ noextract = discid-1.0.0.gem
+ source = http://gems.rubyforge.org/gems/discid-1.0.0.gem
+ md5sums = 4c6d2a1cd5d751fa373f16ca2b74d9ae
+
+pkgname = ruby-discid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..20625a9e1d7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src/*
+pkg/*
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.zip
+*.gem
+*.air
+*.part
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30f7a164d912
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
+_gemname=discid
+pkgname=ruby-$_gemname
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="Ruby bindings for the MusicBrainz DiscID library libdiscid."
+arch=(any)
+url="https://github.com/phw/ruby-discid"
+license=('LGPL3')
+depends=(ruby ruby-ffi libdiscid) # Full dependency information is available in the yaml specification
+makedepends=(rubygems)
+source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+md5sums=(4c6d2a1cd5d751fa373f16ca2b74d9ae)
+
+package() {
+ cd "$srcdir"
+ # _gemdir is defined inside package() because if ruby[gems] is not installed on
+ # the system, makepkg will exit with an error when sourcing the PKGBUILD.
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
+ "$_gemname-$pkgver.gem"
+}
+
+# vim:set ts=2 sw=2 et: