summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-01-07 21:49:03 -0500
committerMario Finelli2016-01-07 21:49:03 -0500
commitd536751939d4dc13fa190b634bd92c82e3e94835 (patch)
tree9698445b7e05e0d77aba6f923e38f9e527d20f79
downloadaur-d536751939d4dc13fa190b634bd92c82e3e94835.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adce2d201120
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 02:49:03 UTC 2016
+pkgbase = ruby-domain_name
+ pkgdesc = This is a Domain Name manipulation library for Ruby. It can also be used for cookie domain validation based on the Public Suffix List.
+ pkgver = 0.5.25
+ pkgrel = 1
+ url = https://github.com/knu/ruby-domain_name
+ arch = any
+ license = BSD-2-Clause
+ license = BSD-3-Clause
+ license = MPL-1.1
+ license = GPL-2.0
+ license = LGPL-2.1
+ makedepends = rubygems
+ depends = ruby
+ depends = ruby-unf
+ noextract = domain_name-0.5.25.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/domain_name-0.5.25.gem
+ sha256sums = 5b492888a095f2f00027a268932c93d0432bf8ada568a5c601ff53ce6a761b9b
+
+pkgname = ruby-domain_name
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0392eba86fb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Generated with gembuild (https://github.com/mfinelli/gembuild)
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+_gemname=domain_name
+pkgname=ruby-$_gemname
+pkgver=0.5.25
+pkgrel=1
+pkgdesc='This is a Domain Name manipulation library for Ruby. It can also be used for cookie domain validation based on the Public Suffix List.'
+arch=('any')
+url='https://github.com/knu/ruby-domain_name'
+license=('BSD-2-Clause' 'BSD-3-Clause' 'MPL-1.1' 'GPL-2.0' 'LGPL-2.1')
+options=(!emptydirs)
+noextract=($_gemname-$pkgver.gem)
+depends=('ruby' 'ruby-unf')
+makedepends=('rubygems')
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+sha256sums=('5b492888a095f2f00027a268932c93d0432bf8ada568a5c601ff53ce6a761b9b')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}