summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Stenglein2021-06-08 18:02:07 -0400
committerMark Stenglein2021-06-08 18:09:13 -0400
commitc583bae1307e403c158fe7fe1613d0c4d3e7341a (patch)
treed8721d2726536eb922a9bbeef7e63da862890783
parentb10cd35c6122d32f6a2e7967ee075ac16f775c24 (diff)
downloadaur-c583bae1307e403c158fe7fe1613d0c4d3e7341a.tar.gz
Bump version to 1.6.5
Also add changelog to package.
-rw-r--r--.CHANGELOG77
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD10
4 files changed, 96 insertions, 11 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
new file mode 100644
index 000000000000..0cc35e804cde
--- /dev/null
+++ b/.CHANGELOG
@@ -0,0 +1,77 @@
+* Add support for /previews endpoint.
+
+1.6.5 (2015-7-28)
+* Update SDK to include a few new fixes
+* Sync up github and rubygems version of this SDK
+
+1.6.4 (2014-4-12)
+* Bugfixes
+* Update gemspec to include all examples
+* Release tests and other internal scripts
+
+1.6.3 (2013-12-11)
+* Stricter SSL: Update certs, use only approved ciphersuites, work around
+ Ruby SSL bugs.
+* Upgrade OAuth 1 tokens with DropboxClient.create_oauth2_access_token and
+ DropboxClient.disable_oauth2_access_token.
+* delta(): Add support for "path_prefix" parameter.
+
+1.6.2 (2013-10-10)
+* Put params in body for POST requests (they were being put in the URL).
+ Fixes bug with /delta and really long cursors.
+
+1.6.1 (2013-07-08)
+* Fixed syntax error (Ruby 1.8.7 didn't mind, but Ruby 1.9 did).
+
+1.6 (2013-07-07)
+* Added OAuth 2 support (DropboxOAuth2Flow). OAuth 1 still works.
+* Fixed many minor bugs.
+
+1.5.1 (2012-8-20)
+* Fixed packaging.
+
+1.5 (2012-8-15)
+* Support for uploading large files via /chunked_upload
+
+1.3.1 (2012-5-16)
+* Increase metadata() file list limit to 25,000 (used to be 10,000).
+* Use CGI.escape() instead of the deprecated URI.escape().
+
+1.3 (2012-3-26)
+* Add support for the /delta API.
+* Add support for the "copy ref" API.
+
+1.2 (2012-1-11)
+* Adds a method to the SDK that returns the file metadata when downloading a
+ file or its thumbnail.
+* Validate server's SSL certificate against CAs in included certificate file.
+
+1.1 (2011-10-17)
+* Various bug fixes found during beta period
+* Improved documentation
+* Improved module structure
+* Removed dependency on the oauth module, using plaintext authentication over https
+
+1.0 (2011-8-16)
+* Backwards compatibility broken
+ - Changed interface
+ - Change 'sandbox' references to 'app_folder'
+* Updated SDK to Dropbox API Version 1, supporting all calls
+ - Added 'rev' parameter to metadata and get_file
+ - Added 'parent_rev' parameter to put_file
+ - Added search, share, media, revisions, and restore
+ - put_file uses /files_put instead of multipart POST
+ - Removed methods for calls that were removed from v1 of the REST API
+* Changed return format for calls
+ - On error (non-200 response), an exception is raised
+ - On success, the JSON is parsed and a Hash is returned
+* Updated examples
+ - Improved CLI example
+ - Added a Ruby on Rails 3 controller example
+ - Added a web based file browser/uploader that uses Sinatra
+* put_file no longer takes a "name" arugment, only takes a full path
+* Removed reliance on config files
+* Assorted bugfixes and improvements
+* All calls are now made over SSL
+* Fully documented code for RDoc generation
+* Added a CHANGELOG
diff --git a/.SRCINFO b/.SRCINFO
index 6662dd1d87bf..c2ba3117e743 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ruby-dropbox-sdk
- pkgdesc = Dropbox REST API Client.
- pkgver = 1.6.4
+ pkgdesc = A library that provides a plain function-call interface to the Dropbox API web endpoints.
+ pkgver = 1.6.5
pkgrel = 1
url = http://www.dropbox.com/developers/
- arch = any
+ arch = x86_64
license = MIT
+ makedepends = rubygems
depends = ruby
- noextract = dropbox-sdk-1.6.4.gem
+ depends = ruby-json
+ noextract = dropbox-sdk-1.6.5.gem
options = !emptydirs
- source = https://rubygems.org/downloads/dropbox-sdk-1.6.4.gem
- sha1sums = 22107a6a987dee16cd9726e2c431734d09e470c3
+ source = https://rubygems.org/downloads/dropbox-sdk-1.6.5.gem
+ sha256sums = 561a18cc4a54bd0480062e80eca54b38709610875c307bcb10aadf95c7a041a3
pkgname = ruby-dropbox-sdk
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3c527050dfff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!.CHANGELOG
diff --git a/PKGBUILD b/PKGBUILD
index 7cda0eec4f55..93ea5628bc95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,19 @@
_gemname=dropbox-sdk
pkgname=ruby-$_gemname
-pkgver=1.6.4
+pkgver=1.6.5
pkgrel=1
-pkgdesc='Dropbox REST API Client.'
+pkgdesc='A library that provides a plain function-call interface to the Dropbox API web endpoints.'
arch=(any)
url='http://www.dropbox.com/developers/'
license=(MIT)
-depends=(ruby)
+depends=('ruby' 'ruby-json')
+makedepends=('rubygems')
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha1sums=('22107a6a987dee16cd9726e2c431734d09e470c3')
+sha256sums=('561a18cc4a54bd0480062e80eca54b38709610875c307bcb10aadf95c7a041a3')
+changelog=.CHANGELOG
package() {
local _gemdir="$(ruby -e'puts Gem.default_dir')"