summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-12-27 21:45:32 -0500
committerMario Finelli2016-12-27 21:45:32 -0500
commitbd79726d0c8ba9545952ac2e92d8fad293830407 (patch)
tree138e686a1f3a47165e56e9a3ff698e9ea0ad4f5c
downloadaur-bd79726d0c8ba9545952ac2e92d8fad293830407.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fbbf314c45f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Wed Dec 28 02:45:14 UTC 2016
+pkgbase = ruby-dry-types
+ pkgdesc = Type system for Ruby supporting coercions, constraints and complex types like structs, value objects, enums etc.
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = https://github.com/dryrb/dry-types
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-concurrent-ruby
+ depends = ruby-dry-configurable
+ depends = ruby-dry-container
+ depends = ruby-dry-core
+ depends = ruby-dry-equalizer
+ depends = ruby-dry-logic
+ depends = ruby-inflecto
+ noextract = dry-types-0.9.3.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/dry-types-0.9.3.gem
+ sha256sums = 2db96a40f4efab0b991fb937c72538e9c58bfc7ee5ab76690bdeb29b1e6e6a8e
+
+pkgname = ruby-dry-types
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d91b3490aa34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=dry-types
+pkgname=ruby-$_gemname
+pkgver=0.9.3
+pkgrel=1
+pkgdesc='Type system for Ruby supporting coercions, constraints and complex types like structs, value objects, enums etc.'
+arch=(any)
+url='https://github.com/dryrb/dry-types'
+license=(MIT)
+depends=(ruby ruby-concurrent-ruby ruby-dry-configurable ruby-dry-container ruby-dry-core ruby-dry-equalizer ruby-dry-logic ruby-inflecto)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('2db96a40f4efab0b991fb937c72538e9c58bfc7ee5ab76690bdeb29b1e6e6a8e')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}