summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReik Keutterling2021-04-17 23:27:18 +0200
committerReik Keutterling2021-04-17 23:27:18 +0200
commit0588b825d9982c108b75b2c200364e4514e7d542 (patch)
tree98d53df6f2504bcedfb9f51453aa464c9775f346
downloadaur-0588b825d9982c108b75b2c200364e4514e7d542.tar.gz
initial release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f26023ba81c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ruby-fusuma-plugin-appmatcher
+ pkgdesc = Fusuma plugin configure app-specific gestures
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/iberianpig/fusuma-plugin-appmatcher
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-fusuma
+ depends = ruby-dbus
+ depends = ruby-rexml
+ noextract = fusuma-plugin-appmatcher-0.1.1.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/fusuma-plugin-appmatcher-0.1.1.gem
+ sha1sums = 55d6953060b43681efdeba5776578fc3575da69f
+
+pkgname = ruby-fusuma-plugin-appmatcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..290e961949ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Reik Keutterling <spielkind at gmail dot com>
+
+_gemname=fusuma-plugin-appmatcher
+pkgname=ruby-$_gemname
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Fusuma plugin configure app-specific gestures"
+arch=(any)
+url="https://github.com/iberianpig/fusuma-plugin-appmatcher"
+license=(MIT)
+depends=(ruby ruby-fusuma ruby-dbus ruby-rexml)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('55d6953060b43681efdeba5776578fc3575da69f')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}