summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReik Keutterling2020-04-03 19:44:24 +0200
committerReik Keutterling2020-04-03 19:44:24 +0200
commit8011a70e34c31fbf8e010e5685fc2b15e9ee5e5a (patch)
tree46e74cc1d2060a28b0db6f919c0459ab7aeebc82
downloadaur-8011a70e34c31fbf8e010e5685fc2b15e9ee5e5a.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ef560fa045a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-fusuma-plugin-wmctrl
+ pkgdesc = Window Manager plugin for Fusuma
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/iberianpig/fusuma-plugin-wmctrl
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-fusuma
+ noextract = fusuma-plugin-wmctrl-0.3.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/fusuma-plugin-wmctrl-0.3.0.gem
+ sha1sums = 2fb51c7f62ba1c5b8c03f0a57d945da9dc25371b
+
+pkgname = ruby-fusuma-plugin-wmctrl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3eae690bfd98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Reik Keutterling <spielkind at gmail dot com>
+
+_gemname=fusuma-plugin-wmctrl
+pkgname=ruby-$_gemname
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Window Manager plugin for Fusuma"
+arch=(any)
+url="https://github.com/iberianpig/fusuma-plugin-wmctrl"
+license=(MIT)
+depends=(ruby ruby-fusuma)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('39527623890bd11fa3a2adcc24d2ccbf7f31d8c1')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}