summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-09-19 22:25:30 -0400
committerMario Finelli2015-09-19 22:25:30 -0400
commitd3c23b55e851aa523a298045a0919ef4266e7be5 (patch)
tree34e086b90be0d3a3bd2290dfa01e0508b158e08b
downloadaur-d3c23b55e851aa523a298045a0919ef4266e7be5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..716e9baac7e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-git
+ pkgdesc = Ruby/Git is a Ruby library that can be used to create, read and manipulate Git repositories by wrapping system calls to the git binary.
+ pkgver = 1.2.9.1
+ pkgrel = 1
+ url = https://github.com/schacon/ruby-git
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ depends = git
+ noextract = git-1.2.9.1.gem
+ source = https://rubygems.org/downloads/git-1.2.9.1.gem
+ sha256sums = 9aa9a279bb45fe8a22e0799a3dbf80d7fd4866bc733256d52fec505829920eeb
+
+pkgname = ruby-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b0fe792aae9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+_gemname=git
+pkgname=ruby-$_gemname
+pkgver=1.2.9.1
+pkgrel=1
+pkgdesc="Ruby/Git is a Ruby library that can be used to create, read and manipulate Git repositories by wrapping system calls to the git binary."
+arch=(any)
+url="https://github.com/schacon/ruby-git"
+license=('MIT')
+depends=('ruby' 'git')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('9aa9a279bb45fe8a22e0799a3dbf80d7fd4866bc733256d52fec505829920eeb')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+}