summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit44175a854fef4186d73754bfc779721e372b072e (patch)
treedb4591e7622eb2d89fceaf54ff2aef997327bd98
downloadaur-44175a854fef4186d73754bfc779721e372b072e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b908e8c8cb78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-html-pipeline
+ pkgdesc = GitHub HTML processing filters and utilities
+ pkgver = 1.11.0
+ pkgrel = 1
+ url = https://github.com/jch/html-pipeline
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-activesupport
+ depends = ruby-nokogiri
+ noextract = html-pipeline-1.11.0.gem
+ source = https://rubygems.org/downloads/html-pipeline-1.11.0.gem
+ sha256sums = 3461d1f709ef4812f11cc9789bdebb801813ba726e5544df3aad6c62336d93f9
+
+pkgname = ruby-html-pipeline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5ab5081ad6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=ruby-html-pipeline
+pkgver=1.11.0
+pkgrel=1
+pkgdesc="GitHub HTML processing filters and utilities"
+arch=('any')
+url="https://github.com/jch/html-pipeline"
+license=('MIT')
+depends=('ruby' 'ruby-activesupport' 'ruby-nokogiri')
+source=(https://rubygems.org/downloads/${pkgname#*-}-${pkgver}.gem)
+sha256sums=('3461d1f709ef4812f11cc9789bdebb801813ba726e5544df3aad6c62336d93f9')
+noextract=("${pkgname#*-}-${pkgver}.gem")
+
+package() {
+ cd "$srcdir"
+
+ msg 'Installing...'
+ gem install \
+ --no-user-install \
+ --ignore-dependencies \
+ -i "$pkgdir$(ruby -rubygems -e'puts Gem.default_dir')" \
+ ${pkgname#*-}-$pkgver.gem
+}