summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-04-08 14:06:51 +0530
committerAnkit R Gadiya2018-04-08 14:06:51 +0530
commitb98e24221769de52a3bb21bed27715a13b3c2a18 (patch)
tree52ad95881f5d0eca80dde5c122b54abab52ea869
parent8d890b483c4d7aa240101a95f7aa29c888bc7e13 (diff)
downloadaur-b98e24221769de52a3bb21bed27715a13b3c2a18.tar.gz
Version Bump, fixed other things
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD31
3 files changed, 47 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32b80bddcee5..b5242f5d14e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Mar 7 01:55:14 UTC 2016
pkgbase = ruby-html-proofer
- pkgdesc = A set of tests to validate your HTML output. These tests check if your image references are legitimate, if they have alt tags, if your internal links are working, and so on. It's intended to be an all-in-one checker for your documentation output.
- pkgver = 3.0.2
+ pkgdesc = Test your rendered HTML files to make sure they are accurate
+ pkgver = 3.7.0
pkgrel = 1
url = https://github.com/gjtorikian/html-proofer
arch = any
@@ -10,16 +8,18 @@ pkgbase = ruby-html-proofer
depends = ruby
depends = ruby-mercenary
depends = ruby-nokogiri
- depends = ruby-colored
- depends = ruby-typhoeus-0
+ depends = ruby-colorize
+ depends = ruby-typhoeus
depends = ruby-yell
depends = ruby-parallel
depends = ruby-addressable
depends = ruby-activesupport
- noextract = html-proofer-3.0.2.gem
+ noextract = html-proofer-3.7.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/html-proofer-3.0.2.gem
- sha1sums = 66ae85ec941720fb8b6fdd9bc2774a68579e22e3
+ source = https://rubygems.org/downloads/html-proofer-3.7.0.gem
+ source = LICENSE
+ sha1sums = fd804e5b09f77353cf5661e13453e719849ed860
+ sha1sums = f90727a909db39508bcfdcfff6e9c225a295dc8a
pkgname = ruby-html-proofer
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f43a35453034
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2013 Garen Torikian
+
+MIT License
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index e873001aaa68..85f26ba1559d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Generated by gem2arch (https://github.com/anatol/gem2arch)
-# Maintainer: Benjamin Chrétien <chretien dot b plus aur at gmail dot com>
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+# Contributor: Benjamin Chrétien <chretien dot b plus aur at gmail dot com>
-_gemname=html-proofer
-pkgname=ruby-$_gemname
-pkgver=3.0.2
+pkgname=ruby-html-proofer
+pkgver=3.7.0
pkgrel=1
-pkgdesc='A set of tests to validate your HTML output. These tests check if your image references are legitimate, if they have alt tags, if your internal links are working, and so on. It'\''s intended to be an all-in-one checker for your documentation output.'
+pkgdesc='Test your rendered HTML files to make sure they are accurate'
arch=(any)
url='https://github.com/gjtorikian/html-proofer'
-license=(MIT)
-depends=(ruby ruby-mercenary ruby-nokogiri ruby-colored ruby-typhoeus-0 ruby-yell ruby-parallel ruby-addressable ruby-activesupport)
+license=('MIT')
+depends=('ruby' 'ruby-mercenary' 'ruby-nokogiri' 'ruby-colorize' 'ruby-typhoeus' 'ruby-yell' 'ruby-parallel' 'ruby-addressable' 'ruby-activesupport')
options=(!emptydirs)
-source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
-noextract=($_gemname-$pkgver.gem)
-sha1sums=('66ae85ec941720fb8b6fdd9bc2774a68579e22e3')
+source=("https://rubygems.org/downloads/html-proofer-${pkgver}.gem"
+ "LICENSE")
+noextract=("html-proofer-${pkgver}.gem")
+sha1sums=('fd804e5b09f77353cf5661e13453e719849ed860'
+ 'f90727a909db39508bcfdcfff6e9c225a295dc8a')
package() {
- local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
- rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" "html-proofer-${pkgver}.gem"
+ rm "${pkgdir}/${_gemdir}/cache/html-proofer-${pkgver}.gem"
- chmod a+x "$pkgdir/usr/bin/htmlproofer"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}