summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsum012017-11-17 00:10:17 -0500
committersum012017-11-17 00:10:17 -0500
commit88a5932ab31796381a945d0a5d4f759401583633 (patch)
treef79a20943fad589105f89b798658e9c910f9ccf9
downloadaur-88a5932ab31796381a945d0a5d4f759401583633.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c62bcc5d692f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ruby-htmlbeautifier
+ pkgdesc = A normaliser/beautifier for HTML that also understands embedded Ruby. Ideal for tidying up Rails templates.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/threedaymonk/htmlbeautifier
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = ruby
+ noextract = htmlbeautifier-1.3.1.gem
+ source = https://rubygems.org/downloads/htmlbeautifier-1.3.1.gem
+ source = https://github.com/threedaymonk/htmlbeautifier/raw/v1.3.1/COPYING.txt
+ sha512sums = 7f877e98f6bd5c9a809830bd58629889d284b1ce699d8749b4c7ad639d81ab06e2d765fe0ef00915ce2c9f4d7afeb8246191718df7c34cafa6c6d383468de1fe
+ sha512sums = cd6f96797fbc47d26f5a06c9881284729643d3b150c8817ef3de999070b5120bfb93ed9b73f642960ab73520ec710276f3a33edf52fbce87dc0f548b83899960
+
+pkgname = ruby-htmlbeautifier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d45021e424c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: sum01 <sum01@protonmail.com>
+pkgname=ruby-htmlbeautifier
+pkgver=1.3.1
+pkgrel=1
+pkgdesc='A normaliser/beautifier for HTML that also understands embedded Ruby. Ideal for tidying up Rails templates.'
+arch=('i686' 'x86_64')
+url="https://github.com/threedaymonk/htmlbeautifier"
+license=('MIT')
+depends=('ruby')
+source=("https://rubygems.org/downloads/htmlbeautifier-$pkgver.gem"
+ "https://github.com/threedaymonk/htmlbeautifier/raw/v$pkgver/COPYING.txt")
+noextract=("htmlbeautifier-$pkgver.gem")
+sha512sums=('7f877e98f6bd5c9a809830bd58629889d284b1ce699d8749b4c7ad639d81ab06e2d765fe0ef00915ce2c9f4d7afeb8246191718df7c34cafa6c6d383468de1fe'
+ 'cd6f96797fbc47d26f5a06c9881284729643d3b150c8817ef3de999070b5120bfb93ed9b73f642960ab73520ec710276f3a33edf52fbce87dc0f548b83899960')
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" htmlbeautifier-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/htmlbeautifier-$pkgver.gem"
+ install -Dm644 "$srcdir/COPYING.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}