summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2018-02-16 20:40:04 -0500
committerMario Finelli2018-02-16 20:40:04 -0500
commit75934bc6eb5897a07ef4318c3e9d86370b7a612c (patch)
tree64ff7b3b401cd8f45185b1e9b27eaf91bd0a23ae
parent5f0f6c0455c15c5dc6bfbed713d25469ff6c1874 (diff)
downloadaur-75934bc6eb5897a07ef4318c3e9d86370b7a612c.tar.gz
Update to version 3.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04e286d891af..0ef0fa1a6f58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ruby-http
pkgdesc = An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.
- pkgver = 0.9.7
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/httprb/http
arch = any
license = MIT
+ makedepends = ruby-rdoc
depends = ruby
depends = ruby-addressable
depends = ruby-http-cookie
depends = ruby-http-form_data
depends = ruby-http_parser.rb
- noextract = http-0.9.7.gem
+ noextract = http-3.0.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/http-0.9.7.gem
- sha256sums = fd81fa67a0a0b5525ee6d7642cf955676337f91a9b7412ea5817ef58497eb470
+ source = https://rubygems.org/downloads/http-3.0.0.gem
+ sha256sums = da797d880d2d731097ab8ea4431ab7b0905e2cb02b19bcedf87920dc1e9612d7
pkgname = ruby-http
diff --git a/PKGBUILD b/PKGBUILD
index 1b159b16140a..de8d1104dc81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,32 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
_gemname=http
pkgname=ruby-$_gemname
-pkgver=0.9.7
+pkgver=3.0.0
pkgrel=1
pkgdesc="An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests."
arch=(any)
url='https://github.com/httprb/http'
license=(MIT)
depends=(ruby ruby-addressable ruby-http-cookie ruby-http-form_data ruby-http_parser.rb)
+makedepends=(ruby-rdoc)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha256sums=('fd81fa67a0a0b5525ee6d7642cf955676337f91a9b7412ea5817ef58497eb470')
+sha256sums=('da797d880d2d731097ab8ea4431ab7b0905e2cb02b19bcedf87920dc1e9612d7')
package() {
- cd "$srcdir"
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" \
+ $_gemname-$pkgver.gem
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+
+ install -Dm0644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}