summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSigmund2015-08-10 19:14:57 +0100
committerSigmund2015-08-10 19:14:57 +0100
commitb16ebed646e67b85d42d0789b165587006236166 (patch)
tree0b11611484814b8b0d9542006f7b3e370778a1ed
downloadaur-b16ebed646e67b85d42d0789b165587006236166.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63522720af9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-http-cookie
+ pkgdesc = A Ruby library to handle HTTP cookies in a way both compliant with RFCs and compatible with today's major browsers.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/sparklemotion/http-cookie
+ arch = any
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = http-cookie-1.0.2.gem
+ source = http://gems.rubyforge.org/gems/http-cookie-1.0.2.gem
+ sha256sums = bcc1b18b5bc3e9302542c9c7f68f1ac0c3100a65dd2831786172e8676773e233
+
+pkgname = ruby-http-cookie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b02b95aef12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+_gemname=http-cookie
+pkgname=ruby-$_gemname
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A Ruby library to handle HTTP cookies in a way both compliant with RFCs and compatible with today's major browsers."
+arch=(any)
+url="https://github.com/sparklemotion/http-cookie"
+license=('MIT')
+depends=(ruby)
+makedepends=(rubygems)
+source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('bcc1b18b5bc3e9302542c9c7f68f1ac0c3100a65dd2831786172e8676773e233')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
+ "$_gemname-$pkgver.gem"
+}
+
+# vim:set ts=2 sw=2 et: