summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2019-12-15 23:32:54 +0000
committerColin Arnott2019-12-15 23:32:54 +0000
commitfa23d3fdb9eea57e3eff63f77750c785fab6c75a (patch)
treef5ccdd69068d76a00973029a297381962beeea18
parentd2a707ac7b6d3f8713cf606043d001b06e30d025 (diff)
downloadaur-fa23d3fdb9eea57e3eff63f77750c785fab6c75a.tar.gz
1.0.3-3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a64955c864bb..fffe99106ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ruby-http-cookie
pkgdesc = A Ruby library to handle HTTP cookies in a way both compliant with RFCs and compatible with today's major browsers.
pkgver = 1.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sparklemotion/http-cookie
arch = any
license = MIT
makedepends = rubygems
- makedepends = rdoc
+ makedepends = ruby-rdoc
depends = ruby
depends = ruby-domain_name
noextract = http-cookie-1.0.3.gem
diff --git a/PKGBUILD b/PKGBUILD
index cf7864fe9c8d..3c4152dfc47a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
_gemname=http-cookie
pkgname=ruby-$_gemname
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="A Ruby library to handle HTTP cookies in a way both compliant with RFCs and compatible with today's major browsers."
arch=(any)
url="https://github.com/sparklemotion/http-cookie"
license=('MIT')
depends=(ruby ruby-domain_name)
-makedepends=(rubygems rdoc)
+makedepends=(rubygems ruby-rdoc)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha256sums=('2f11269d817bc52ab2af2721e89a377660a961078de2a3a55fc696d7897e8c00')
package() {
cd "$srcdir"
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _gemdir="$(ruby -r rubygems -e'puts Gem.default_dir')"
gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
"$_gemname-$pkgver.gem"